f6bff99e09
PR: 139531 Submitted by: Matthias Andree <matthias.andree@gmx.de> (maintainer)
58 lines
2.4 KiB
Text
58 lines
2.4 KiB
Text
--- a/misc/Makefile.in.orig 2009-08-23 04:44:35.000000000 +0200
|
|
+++ b/misc/Makefile.in 2009-10-11 23:07:27.000000000 +0200
|
|
@@ -25,14 +25,14 @@
|
|
|
|
SPROGS= mke2fs badblocks tune2fs dumpe2fs $(BLKID_PROG) logsave \
|
|
$(E2IMAGE_PROG) @FSCK_PROG@ e2undo
|
|
-USPROGS= mklost+found filefrag e2freefrag $(UUIDD_PROG)
|
|
+USPROGS= mklost+found e2freefrag
|
|
SMANPAGES= tune2fs.8 mklost+found.8 mke2fs.8 dumpe2fs.8 badblocks.8 \
|
|
e2label.8 $(FINDFS_MAN) $(BLKID_MAN) $(E2IMAGE_MAN) \
|
|
- logsave.8 filefrag.8 e2freefrag.8 e2undo.8 $(UUIDD_MAN) @FSCK_MAN@
|
|
+ logsave.8 e2freefrag.8 e2undo.8 @FSCK_MAN@
|
|
FMANPAGES= mke2fs.conf.5
|
|
|
|
-UPROGS= chattr lsattr @UUID_CMT@ uuidgen
|
|
-UMANPAGES= chattr.1 lsattr.1 @UUID_CMT@ uuidgen.1
|
|
+UPROGS= chattr lsattr
|
|
+UMANPAGES= chattr.1 lsattr.1
|
|
|
|
LPROGS= @E2INITRD_PROG@
|
|
|
|
@@ -466,34 +466,9 @@
|
|
echo " INSTALL_DATA $(man5dir)/$$i"; \
|
|
$(INSTALL_DATA) $$i $(DESTDIR)$(man5dir)/$$i; \
|
|
done
|
|
- $(Q) if test -f $(DESTDIR)$(root_sysconfdir)/mke2fs.conf; then \
|
|
- if cmp -s $(DESTDIR)$(root_sysconfdir)/mke2fs.conf \
|
|
- $(srcdir)/mke2fs.conf; then \
|
|
- true; \
|
|
- else \
|
|
- if grep -q ext4dev $(DESTDIR)$(root_sysconfdir)/mke2fs.conf ; then \
|
|
- echo " INSTALL_DATA $(root_sysconfdir)/mke2fs.conf.e2fsprogs-new"; \
|
|
- $(INSTALL_DATA) $(srcdir)/mke2fs.conf \
|
|
- $(DESTDIR)$(root_sysconfdir)/mke2fs.conf.e2fsprogs-new; \
|
|
- echo "Warning: installing mke2fs.conf in $(DESTDIR)$(root_sysconfdir)/mke2fs.conf.e2fsprogs-new"; \
|
|
- echo "Check to see if you need to update your $(root_sysconfdir)/mke2fs.conf"; \
|
|
- else \
|
|
- echo " INSTALL_DATA $(root_sysconfdir)/mke2fs.conf"; \
|
|
- mv $(DESTDIR)$(root_sysconfdir)/mke2fs.conf \
|
|
- $(DESTDIR)$(root_sysconfdir)/mke2fs.conf.e2fsprogs-old; \
|
|
- $(INSTALL_DATA) $(srcdir)/mke2fs.conf \
|
|
- $(DESTDIR)$(root_sysconfdir)/mke2fs.conf; \
|
|
- echo "Your mke2fs.conf is too old. Backing up old version in"; \
|
|
- echo "$(DESTDIR)$(root_sysconfdir)/mke2fs.conf.e2fsprogs-old. Please check to see"; \
|
|
- echo "if you have any local customizations that you wish to preserve."; \
|
|
- fi; \
|
|
- echo " "; \
|
|
- fi; \
|
|
- else \
|
|
- echo " INSTALL_DATA $(root_sysconfdir)/mke2fs.conf"; \
|
|
+ $(Q) echo " INSTALL_DATA $(root_sysconfdir)/mke2fs.conf"; \
|
|
$(INSTALL_DATA) $(srcdir)/mke2fs.conf \
|
|
- $(DESTDIR)$(root_sysconfdir)/mke2fs.conf; \
|
|
- fi
|
|
+ $(DESTDIR)$(root_sysconfdir)/mke2fs.conf.dist
|
|
|
|
install-strip: install
|
|
$(Q) for i in $(SPROGS); do \
|