This port contains a number of tools for manupilating v4l* devices. Initial port of 0.8.3 by nox@, some polish and update to 0.8.4 by myself.
24 lines
1.1 KiB
Text
24 lines
1.1 KiB
Text
--- keytable/Makefile.orig 2011-06-01 13:23:03.000000000 +0200
|
|
+++ keytable/Makefile 2011-06-04 09:43:14.000000000 +0200
|
|
@@ -34,12 +34,14 @@
|
|
install: $(TARGETS)
|
|
mkdir -p $(DESTDIR)$(PREFIX)/bin $(DESTDIR)/etc
|
|
install -m 755 $(TARGETS) $(DESTDIR)$(PREFIX)/bin
|
|
- install -m 644 -p rc_maps.cfg $(DESTDIR)/etc
|
|
- install -m 755 -d $(DESTDIR)/etc/rc_keymaps
|
|
- install -m 644 -p rc_keymaps/* $(DESTDIR)/etc/rc_keymaps
|
|
- install -m 755 -d $(DESTDIR)/lib/udev/rules.d
|
|
- install -m 644 -p 70-infrared.rules $(DESTDIR)/lib/udev/rules.d
|
|
- install -m 755 -d $(DESTDIR)$(MANDIR)/man1
|
|
- install -m 644 -p ir-keytable.1 $(DESTDIR)$(MANDIR)/man1
|
|
+ install -m 644 -p rc_maps.cfg $(DESTDIR)$(PREFIX)/etc
|
|
+ install -m 755 -d $(DESTDIR)$(PREFIX)/etc/rc_keymaps
|
|
+ install -m 644 -p rc_keymaps/* $(DESTDIR)$(PREFIX)/etc/rc_keymaps
|
|
+ifdef UDEV
|
|
+ install -m 755 -d $(DESTDIR)$(PREFIX)/etc/udev/rules.d
|
|
+ install -m 644 -p 70-infrared.rules $(DESTDIR)$(PREFIX)/etc/udev/rules.d
|
|
+endif
|
|
+ install -m 755 -d $(DESTDIR)$(PREFIX)/man/man1
|
|
+ install -m 644 -p ir-keytable.1 $(DESTDIR)$(PREFIX)/man/man1
|
|
|
|
include ../../Make.rules
|