- Add Makefile.common o A new build/install system for gecko ports, Makefile.common includes many generic routines and common tasks. o Fix ld-run-path in all gecko's by using -Wl,-rpath,${moz_libdir} thus removing the need to have a startup script for ports that depend on gecko. [2] o Use system libm, nss, nspr in all gecko ports - Add bsd.gecko.mk o This is the predecessor to WITH_MOZILLA=[mozilla|firefox|...] with a more robust way of detecting a gecko a end user wishs to use. o bsd.gecko.mk abstracts the selection of gecko-based backends. It allows users and porters to support any available gecko backend without needing to build many conditional tests. ${USE_GECKO} is the list of backends that your port can handle, and ${GECKO} is set by bsd.gecko.mk to be the chosen backend. Users set ${WITH_GECKO} to the list of gecko backends they want on their system. Port Makefile example: USE_GECKO=firefox mozilla seamonkey thunderbird .include <bsd.port.pre.mk> .include "${.CURDIR}/../../www/mozilla/bsd.gecko.mk" End user example: WITH_GECKO=seamonkey firefox We highly recommend moving away from using WITH_MOZILLA and switching to USE/WITH_GECKO. PR: 89052 [2] Submitted by: vs [2] Obtained from: www/firefox Thanks to: adamw, marcus, and mezz for ideas, bug squashing, and more sajd from irc.freenode.org/#FreeBSD-Gnome for pointing out many bugs
13 lines
397 B
C
13 lines
397 B
C
$FreeBSD$
|
|
$MCom: ports/www/firefox/files/patch-config-mkdepend-imakemdep.h,v 1.7 2005/11/11 00:15:48 ahze Exp $
|
|
|
|
--- config/mkdepend/imakemdep.h Fri Sep 4 21:22:25 1998
|
|
+++ config/mkdepend/imakemdep.h Thu Oct 16 22:43:25 2003
|
|
@@ -278,4 +278,7 @@
|
|
"-D__i386__",
|
|
# endif
|
|
+# if defined(__amd64__) || defined(__x86_64__)
|
|
+ "-D__amd64__ -D__x86_64__",
|
|
+# endif
|
|
# ifdef __GNUC__
|
|
"-traditional",
|