freebsd-ports/emulators/qemu/files/patch-meson.build
Muhammad Moinur Rahman 7eac6b77c1 emulators/qemu: Update version 6.2.0=>7.0.0
Users who want to stick with 6.X branch please check UPDATING or use
qemu6. As previous qemu comes with three flavors: the default with X11
support, -nox11 without X11 support and -tools which instals only a
subset of entire qemu.

Relnotes: https://wiki.qemu.org/ChangeLog/7.0
2022-04-23 19:40:24 -05:00

20 lines
970 B
Text

--- meson.build.orig 2022-04-19 19:10:27 UTC
+++ meson.build
@@ -2505,14 +2505,10 @@ if have_system
fdt_opt = get_option('fdt')
if fdt_opt in ['enabled', 'auto', 'system']
have_internal = fs.exists(meson.current_source_dir() / 'dtc/libfdt/Makefile.libfdt')
- fdt = cc.find_library('fdt', kwargs: static_kwargs,
+ fdt = cc.find_library('fdt', kwargs: static_kwargs, dirs: '/usr/local/lib/',
required: fdt_opt == 'system' or
- fdt_opt == 'enabled' and not have_internal)
- if fdt.found() and cc.links('''
- #include <libfdt.h>
- #include <libfdt_env.h>
- int main(void) { fdt_find_max_phandle(NULL, NULL); return 0; }''',
- dependencies: fdt)
+ fdt_opt == 'enabled')
+ if fdt.found()
fdt_opt = 'system'
elif fdt_opt == 'system'
error('system libfdt requested, but it is too old (1.5.1 or newer required)')