freebsd-ports/lang/caml-light/files/patch-contrib_libgraph_Makefile
Martin Wilke 3e4ed01146 - Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG
- Remove X11BASE support in favor of LOCALBASE or PREFIX
- Use USE_LDCONFIG instead of INSTALLS_SHLIB
- Remove unneeded USE_GCC 3.4+

Thanks to all Helpers:
	Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr,
	ehaupt, nox, itetcu, flz, pav

PR:		116263
Tested on:	pointyhat
Approved by:	portmgr (pav)
2008-04-19 17:56:05 +00:00

38 lines
992 B
Text

--- ./contrib/libgraph/Makefile-- Thu Dec 24 00:36:55 1998
+++ ./contrib/libgraph/Makefile Sun Aug 6 11:37:59 2006
@@ -1,17 +1,17 @@
# Makefile for the portable graphics library
# These options are overriden when called from ../Makefile
-CC=cc
+#CC=cc
OPTS=
-X11_INCLUDES=/usr/include
-X11_LIB=/usr/lib
-CPP=/lib/cpp -P
+X11_INCLUDES=${LOCALBASE}
+X11_LIB=${LOCALBASE}/lib
+CPP=/usr/bin/cpp -P
-BINDIR=/usr/local/bin
-LIBDIR=/usr/local/lib/caml-light
+BINDIR=${PREFIX}/bin
+LIBDIR=${PREFIX}/lib/caml-light
# Compilation options
-CFLAGS=$(OPTS) -I../../src/runtime -I$(X11_INCLUDES) -O
+CFLAGS+=$(OPTS) -I../../src/runtime -I$(X11_INCLUDES)
# Test to see whether ranlib exists on the machine
RANLIBTEST=test -f /usr/bin/ranlib -o -f /bin/ranlib
@@ -20,8 +20,8 @@
RANLIB=ranlib
# The Caml Light compilers
-CAMLC=camlc
-CAMLMKTOP=camlmktop
+CAMLC=${PREFIX}/bin/camlc
+CAMLMKTOP=${PREFIX}/bin/camlmktop
COMPFLAGS=-W -I ../libunix
OBJS=open.o draw.o fill.o color.o text.o \