freebsd-ports/editors/xenon/files/patch-Makefile.common
Alexey Dokuchaev b0b0e402f2 - Fix the build with recent GCC [1]
- Conveniently redefine PORTEXAMPLES
- Clean up Makefile
- Improve upon port description
- Respect NOPORTEXAMPLES
- Drop now useless USE_GCC and USE_X_PREFIX

Reported by:	pointyhat (logs) [1]
2007-07-02 19:10:41 +00:00

20 lines
648 B
Text

--- makefiles/Makefile.common.orig Sat Aug 4 16:59:06 2001
+++ makefiles/Makefile.common Fri Dec 1 20:33:15 2006
@@ -67,7 +67,7 @@
MKDEPEND = ./mkdepend
DEPEND = .depend
-_CCFLAGS = $(ARCH) $(CCFLAGS) $(INCLUDES)
+_CCFLAGS = $(CCFLAGS) $(INCLUDES)
_LDFLAGS = $(TARGETLIB) $(LIBS)
#LDFLAGS = $(TARGETLIB) -lXpm -lX11
@@ -94,7 +94,7 @@
# $(CC) -shared -o $(TARGETSO) $(OBJECTS)
$(TARGET): $(TARGETLIB) $(AUXTARGET).o
- $(CC) $(ARCH) $(LDFLAGS) $(AUXTARGET).o $(_LDFLAGS) -o $(TARGET)
+ $(CXX) $(LDFLAGS) $(AUXTARGET).o $(_LDFLAGS) -o $(TARGET)
#$(SHTARGET): $(TARGETSO) $(TARGET).o
# $(CC) -o $(TARGET) -g $(TARGET).o $(SHLDFLAGS)