freebsd-ports/graphics/p5-Gimp/files/patch-examples__Makefile.PL
Sunpoet Po-Chuan Hsieh 3d283e42f8 Update to 2.32
- Add LICENSE_FILE

Changes:	http://search.cpan.org/dist/Gimp/Changes
2017-04-11 15:56:34 +00:00

21 lines
571 B
Raku

--- examples/Makefile.PL.orig 2016-05-01 01:47:52 UTC
+++ examples/Makefile.PL
@@ -47,7 +47,8 @@ sub install_plugin_target {
my $dest = '$(GIMP_PLUGINS)/'.basename($plugin);
<<EOF;
$dest : $src
- \$(NOECHO) \$(GTINSTALL) "$src"
+ \$(NOECHO) \$(MKPATH) \$(GIMP_PLUGINS)
+ \$(CP) "$src" "$dest"
EOF
}
@@ -73,7 +74,7 @@ undef &MY::postamble; # suppress warning
<<EOF;
INST_PLUGINS = ../blib/plugins
-GIMP_PLUGINS = $plugindir
+GIMP_PLUGINS = \$(DESTDIR)$plugindir
\$(INST_PLUGINS)\$(DFSEP).exists :: Makefile.PL
\$(NOECHO) \$(MKPATH) \$(INST_PLUGINS)