* PrintableOptions.cmake: Correct variable name comparison (CMake 3.20.1 issue) * SetupBuildFlags.cmake: Correct testing of two compiler/linker build flags (fix build with clang11+/gcc10+) Regen patches by 'make makepatch' Obtained from: gitlab.gnome.org repository Approved by: portmgr blanket (trivial build fix)
10 lines
402 B
Text
10 lines
402 B
Text
--- CMakeLists.txt.orig 2021-04-23 14:06:10 UTC
|
|
+++ CMakeLists.txt
|
|
@@ -356,6 +356,7 @@ endif(WITH_HELP)
|
|
# ******************************
|
|
|
|
set(CMAKE_REQUIRED_LIBRARIES "-liconv")
|
|
+set(CMAKE_REQUIRED_FLAGS "-L/usr/local/lib")
|
|
CHECK_C_SOURCE_COMPILES("#include <iconv.h>
|
|
#include <stdlib.h>
|
|
int main(void) { iconv_t cd; cd = iconv_open (\"UTF-8\", \"ISO-8859-1\"); return 0; }" HAVE_LIBICONV)
|