This update fixes bugs like CVE-2018-2696, CVE-2018-2562, CVE-2018-2640, CVE-2018-2668, CVE-2017-3737 (and more) in MySQL protocol by upstream. Delete local patches (CMake plugin macros) that are merged by upstream. PR: 225195 Sponsored by: Netzkommune GmbH
29 lines
1.1 KiB
Text
29 lines
1.1 KiB
Text
--- libmysql/CMakeLists.txt.orig 2016-03-28 18:06:12 UTC
|
|
+++ libmysql/CMakeLists.txt
|
|
@@ -235,7 +235,7 @@ MESSAGE(STATUS
|
|
ADD_SUBDIRECTORY(authentication_ldap)
|
|
|
|
# Merge several convenience libraries into one big mysqlclient
|
|
-MERGE_CONVENIENCE_LIBRARIES(mysqlclient ${LIBS} COMPONENT Development)
|
|
+MERGE_CONVENIENCE_LIBRARIES(mysqlclient ${LIBS} COMPONENT Development SKIP_INSTALL)
|
|
|
|
# Visual Studio users need debug static library for debug projects
|
|
IF(MSVC)
|
|
@@ -257,7 +257,8 @@ IF(NOT DISABLE_SHARED)
|
|
# and link them together into shared library.
|
|
MERGE_LIBRARIES(libmysql SHARED ${LIBS}
|
|
EXPORTS ${CLIENT_API_FUNCTIONS} ${CLIENT_API_FUNCTIONS_UNDOCUMENTED}
|
|
- COMPONENT SharedLibraries)
|
|
+ COMPONENT SharedLibraries SKIP_INSTALL)
|
|
+IF(FALSE)
|
|
IF(UNIX)
|
|
# libtool compatability
|
|
IF(CMAKE_SYSTEM_NAME MATCHES "FreeBSD" OR APPLE)
|
|
@@ -313,6 +314,7 @@ ENDIF()
|
|
# to initialize api_calls[] array in api_test.c
|
|
#
|
|
SET(CLIENT_API_FUNCTION_LIST "")
|
|
+ ENDIF()
|
|
FOREACH(api ${CLIENT_API_FUNCTIONS})
|
|
SET(CLIENT_API_FUNCTION_LIST "${CLIENT_API_FUNCTION_LIST} ${api},")
|
|
ENDFOREACH()
|