freebsd-ports/editors/emacs/files/patch-src_term.c
Ashish SHUKLA 7fc5bd70f3 GNU Emacs updates
editors/emacs:
 - Update to 24.3
 - Update CANNA patchset[1]
 - Unbreak ARM support by using the patch from emacs-devel port
 - Add missing INSTALLS_ICONS[2]
 - Remove a patch which is already integrated upstream
 - Fix Makefile header

editors/emacs-devel:
 - Update to bzr revision 112178
 - Fix Makefile header
 - Add missing INSTALLS_ICONS[2]

editors/emacs23:
 - Remove ABI versions from LIB_DEPENDS
 - Fix Makefile header
 - Add missing INSTALLS_ICONS[2]

Mk/bsd.emacs.mk:
 - Update major version for editors/emacs port

*:
 - Bump PORTREVISION to chase Emacs updates

PR:		ports/177428[2]
Submitted by:	Yuji TAKANO[1] (via private email), bdrewery[2]
2013-03-30 05:13:30 +00:00

23 lines
672 B
C

$FreeBSD$
$NetBSD: patch-ag,v 1.13 2010/05/15 10:00:57 roy Exp $
When running terminfo but compiled for termcap, we cannot assume
that we actually have anything useable in termcap_term_buffer so just
use the terminfo fixed size defined ealier.
--- src/term.c.orig
+++ src/term.c
@@ -3111,11 +3111,6 @@
terminal_type);
}
-#ifndef TERMINFO
- if (strlen (tty->termcap_term_buffer) >= buffer_size)
- emacs_abort ();
- buffer_size = strlen (tty->termcap_term_buffer);
-#endif
tty->termcap_strings_buffer = area = xmalloc (buffer_size);
tty->TS_ins_line = tgetstr ("al", address);
tty->TS_ins_multi_lines = tgetstr ("AL", address);