bdb06fad8a
- Don't use trac/plugin.mk which is now empty and unneeded - Add some NO_ARCH'es - Add/fix some LICENSEs and LICENSE_FILES - Pet portlint - Regenerate some patches Approved by: portmgr blanket
12 lines
467 B
Python
12 lines
467 B
Python
--- trackeywords/web_ui.py.orig 2009-09-09 13:18:34 UTC
|
|
+++ trackeywords/web_ui.py
|
|
@@ -80,7 +80,8 @@ class TracKeywordsComponent(core.Compone
|
|
|
|
# changed to Genshi signature
|
|
def post_process_request(self, req, template, data, content_type):
|
|
- data['keywords'] = self._get_keywords()
|
|
+ if data is not None:
|
|
+ data['keywords'] = self._get_keywords()
|
|
return (template, data, content_type)
|
|
|
|
### ITemplateProvider methods
|