Cdrdao changes: o Man page cleanup (Andrew Suffield) GCDMaster changes: o Fixed GCC 4.1 compilation issues o Fixed hang when inserting WAV file - Ensure that the libraries built by the port are linked in and not already installed ones. For example in case of libcdda_paranoia installed by audio/cdparanoia can't be used to build cddao. Such problems only happen when using non-standard compiler and/or linker flags are used but it doesn't hurt to add some anti-footshooting measurements to the port. [1] PR: 115616 [1] Approved by: netchild
15 lines
677 B
Text
15 lines
677 B
Text
--- xdao/Makefile.in.orig 2006-09-20 10:51:34.000000000 +0000
|
|
+++ xdao/Makefile.in 2007-08-31 22:33:12.000000000 +0000
|
|
@@ -341,9 +341,9 @@
|
|
glade_DATA = \
|
|
glade/ProjectChooser.glade
|
|
|
|
-gcdmaster_LDADD = @sound_if_obj@ -L$(top_builddir)/dao -ldao \
|
|
- -L$(top_builddir)/paranoia -lcdda_paranoia \
|
|
- -L$(top_builddir)/trackdb -ltrackdb @scsilib_libs@ \
|
|
+gcdmaster_LDADD = @sound_if_obj@ $(top_builddir)/dao/libdao.a \
|
|
+ $(top_builddir)/paranoia/libcdda_paranoia.a \
|
|
+ $(top_builddir)/trackdb/libtrackdb.a @scsilib_libs@ \
|
|
@LIBGUIMM2_LIBS@ @GTKMM2_LIBS@ $(am__append_1) $(am__append_3) \
|
|
@AO_LIBS@ $(am__empty)
|
|
AM_CXXFLAGS = @GTKMM2_CFLAGS@ @LIBGUIMM2_CFLAGS@ @AO_CFLAGS@ \
|