Changes happened into format of --version which caused r450384 Reviewed by: mat (mentor) Approved by: mat (mentor) Sponsored by: Netzkommune GmbH Differential Revision: https://reviews.freebsd.org/D12579
23 lines
774 B
Text
23 lines
774 B
Text
--- libmysql/CMakeLists.txt.orig 2017-06-27 11:44:29 UTC
|
|
+++ libmysql/CMakeLists.txt
|
|
@@ -181,6 +181,11 @@ IF (WIN32 AND OPENSSL_APPLINK_C)
|
|
)
|
|
ENDIF()
|
|
|
|
+INCLUDE(${MYSQL_CMAKE_SCRIPT_DIR}/compile_flags.cmake)
|
|
+IF (CMAKE_SYSTEM_NAME STREQUAL "FreeBSD")
|
|
+ ADD_COMPILE_FLAGS(${CLIENT_SOURCES} COMPILE_FLAGS "-fPIC")
|
|
+ENDIF()
|
|
+
|
|
#
|
|
# Include protocol tracing infrastructure and the test
|
|
# trace plugin if enabled by build options.
|
|
@@ -254,7 +258,7 @@ IF(NOT DISABLE_SHARED)
|
|
COMPONENT SharedLibraries)
|
|
IF(UNIX)
|
|
# libtool compatability
|
|
- IF(CMAKE_SYSTEM_NAME MATCHES "FreeBSD" OR APPLE)
|
|
+ IF(CMAKE_SYSTEM_NAME MATCHES "FreeBSD|DragonFly" OR APPLE)
|
|
SET(OS_SHARED_LIB_VERSION "${SHARED_LIB_MAJOR_VERSION}")
|
|
ELSE()
|
|
SET(OS_SHARED_LIB_VERSION
|