freebsd-ports/textproc/nltk/files/patch-setup.py
Ruslan Makhmatkhanov 7e400d5d0e - update to 2.0.2
- change mastersites to pypi, because google doesn't carry the latest tarball
- drop unneeded BUILD_DEPENDS, LICENSE_FILE, USE_PYTHON_PREFIX,
  PYDISTUTILS_EGGINFO
- create pkg-plist
- install with setuptools (upstream switched to it via distribute)
- strict python versions to 2.x only
- add patch to not use distribute for installing. distribute conflicts with
  setuptools. this may be dropped when the whole ports tree will be switched to
  distribute.

PR:		170515
Submitted by:	rm (myself)
Approved by:	maintainer timeout (1 month)
2012-09-11 18:01:59 +00:00

12 lines
305 B
Python

--- setup.py.orig 2012-02-06 14:55:59.000000000 +0400
+++ setup.py 2012-08-09 14:41:28.000000000 +0400
@@ -19,9 +19,6 @@
with open(version_file) as fh:
nltk_version = fh.read().strip()
-import distribute_setup
-distribute_setup.use_setuptools()
-
from setuptools import setup, find_packages
#