131cd97388
editors/emacs19, and update the main emacs port to 21.x by copying from editors/emacs21. Retire the editors/emacs21 port. PR: ports/24983
37 lines
1.2 KiB
Text
37 lines
1.2 KiB
Text
--- configure.in.orig Sun Mar 16 17:06:05 2003
|
|
+++ configure.in Thu Mar 18 13:31:10 2004
|
|
@@ -179,6 +179,18 @@
|
|
machine='' opsys='' unported=no
|
|
case "${canonical}" in
|
|
|
|
+ ## FreeBSD ports
|
|
+ *-*-freebsd* )
|
|
+ opsys=freebsd
|
|
+ case "${canonical}" in
|
|
+ alpha*-*-freebsd*) machine=alpha ;;
|
|
+ amd64-*-freebsd*) machine=amd64 ;;
|
|
+ ia64-*-freebsd*) machine=ia64 ;;
|
|
+ i[3456]86-*-freebsd*) machine=intel386 ;;
|
|
+ sparc64-*-freebsd*) machine=sparc ;;
|
|
+ esac
|
|
+ ;;
|
|
+
|
|
## NetBSD ports
|
|
*-*-netbsd* )
|
|
opsys=netbsd
|
|
@@ -1032,7 +1044,6 @@
|
|
;;
|
|
*-sysv4.2uw* ) opsys=unixware; NON_GNU_CPP=/lib/cpp ;;
|
|
*-386bsd* ) opsys=386bsd ;;
|
|
- *-freebsd* ) opsys=freebsd ;;
|
|
*-nextstep* ) opsys=nextstep ;;
|
|
## Otherwise, we'll fall through to the generic opsys code at the bottom.
|
|
esac
|
|
@@ -2050,6 +2061,7 @@
|
|
# Solaris requires -lintl if you want strerror (which calls dgettext)
|
|
# to return localized messages.
|
|
AC_CHECK_LIB(intl, dgettext)
|
|
+AC_CHECK_LIB(xpg4, _xpg4_setrunelocale)
|
|
|
|
AC_MSG_CHECKING(whether localtime caches TZ)
|
|
AC_CACHE_VAL(emacs_cv_localtime_cache,
|