freebsd-ports/math/parmetis/files/patch-CMakeLists.txt
Thierry Thomas 85b8b7169f - build the shared libraries by defaulti (used by Code_Saturne);
- add an option to keep the static ones;

- add an external pkg-plist.
2018-11-03 10:30:49 +00:00

13 lines
364 B
Text

--- CMakeLists.txt.orig 2013-03-30 16:24:50 UTC
+++ CMakeLists.txt
@@ -19,8 +19,10 @@ execute_process(COMMAND ${CMAKE_COMMAND}
# Prepare libraries.
if(SHARED)
set(ParMETIS_LIBRARY_TYPE SHARED)
+ set(METIS_LIBRARY_TYPE SHARED)
else()
set(ParMETIS_LIBRARY_TYPE STATIC)
+ set(METIS_LIBRARY_TYPE STATIC)
endif()
include(${GKLIB_PATH}/GKlibSystem.cmake)