to track the things down. There are known problems with weak symbols and exceptions. Some c++ tools inside the port will fail if you try to compile. The cpp_uno bridge has been updated to the latest linux version available. Added 'make update' target to upgrade the source to the latest version. Approved by: kris (portmgr)
12 lines
376 B
Makefile
12 lines
376 B
Makefile
--- ../soltools/checkdll/makefile.mk.orig Tue Mar 11 14:21:02 2003
|
|
+++ ../soltools/checkdll/makefile.mk Tue Mar 11 14:21:30 2003
|
|
@@ -80,7 +80,9 @@
|
|
APP1TARGET = checkdll
|
|
APP1OBJS = $(OBJ)$/checkdll.obj
|
|
DEPOBJFILES = $(APP1OBJS)
|
|
+.IF "$(OS)"!="FREEBSD"
|
|
STDLIB += -ldl
|
|
+.ENDIF
|
|
.IF "$(OS)"=="NETBSD"
|
|
APP1STDLIBS += -Wl,--whole-archive -lgcc -Wl,--no-whole-archive
|
|
.ENDIF
|