32 lines
916 B
Text
32 lines
916 B
Text
--- src/Makefile.orig Tue Apr 10 21:37:01 2001
|
|
+++ src/Makefile Sat Jun 9 17:09:29 2001
|
|
@@ -9,7 +9,7 @@
|
|
# This gets definitions for CC, CFLAGS, BINDIR etc.
|
|
include ../config.mk
|
|
|
|
-CFLAGS+=-DBACKEND_$(BACKEND) `gtk-config --cflags`
|
|
+CFLAGS+=-DBACKEND_$(BACKEND) `${GTK_CONFIG} --cflags`
|
|
|
|
# I could do this less horribly if I made it GNU-make-specific,
|
|
# but I decided not to. And here we are. :-(
|
|
@@ -30,7 +30,7 @@
|
|
# compile when you do `make install'. :-)
|
|
# (It would also be weird to have it made by the `doc' Makefile, IMHO.)
|
|
|
|
-all: xzgv install-info
|
|
+all: xzgv #install-info
|
|
|
|
OBJS= main.o \
|
|
filedetails.o gotodir.o updatetn.o confirm.o help.o \
|
|
@@ -57,9 +57,8 @@
|
|
installdirs:
|
|
/bin/sh ../mkinstalldirs $(BINDIR)
|
|
|
|
-install: xzgv installdirs
|
|
- install xzgv $(BINDIR)
|
|
- chmod 755 $(BINDIR)/xzgv
|
|
+install: xzgv #installdirs
|
|
+ ${BSD_INSTALL_PROGRAM} xzgv $(BINDIR)
|
|
|
|
uninstall:
|
|
$(RM) $(BINDIR)/xzgv
|