freebsd-ports/editors/openoffice.org-2.0-devel/files/patch-stlport+makefile.mk
Martin Blapp 6f36732a2d Make openoffice compile with gcc from ports, or just with CC=$CC and
CXX=$CXX, like it should normally be. Usable options are:

USEPORTGCC295=YES, USEPORTGCC31=YES and USEPORTGCC32=YES

Add a lot off gcc3.x fixes, make included stlport compile with CURRENT.

Next step will be to include a mozilla build, so we can link openoffice
against mozilla librarys without c++ compat problems.
2002-05-29 13:58:09 +00:00

32 lines
554 B
Makefile

--- ../stlport/makefile.mk.orig Tue Mar 19 15:49:17 2002
+++ ../stlport/makefile.mk Tue May 28 23:03:45 2002
@@ -106,11 +106,29 @@
.IF "$(COM)"=="GCC"
.IF "$(COMID)"=="gcc3"
+
+.IF "$(OS)"=="FREEBSD"
+BUILD_FLAGS=-f gcc-3.0-freebsd.mak
+.ELSE
BUILD_FLAGS=-f gcc-3.0.mak
+.ENDIF
+
.ELSE # "$(COMID)"=="gcc3"
+
+.IF "$(OS)"=="FREEBSD"
+BUILD_FLAGS=-f gcc-freebsd.mak
+.ELSE
BUILD_FLAGS=-f gcc.mak
+.ENDIF
+
.ENDIF # "$(COMID)"=="gcc3"
+
+.IF "$(OS)"=="FREEBSD"
+BUILD_ACTION=gmake
+.ELSE
BUILD_ACTION=make
+.ENDIF
+
.ENDIF
.IF "$(COM)"=="C52"