freebsd-ports/x11/xloadimage/files/patch-build-info
Alex Kozlov 54ffbcf921 - Regenerate distinfo
- Fix build when Samba is installed and configured as PDC [1]
- Make build reproducible [2]

PR:	209724
Submitted by:	mail_of_sergey@mail.ru
Submitted by:	amdmi3 [1] [2]
2016-06-06 04:42:15 +00:00

35 lines
829 B
Text

Index: build-info
@@ -3,32 +3,16 @@
# try to find out the build date
-if [ -x /bin/date ]; then
- date='char *BuildDate= "'`/bin/date`'";'
-else
date='char *BuildDate= (char *)0;'
-fi
# try to find out who's doing the build. there are two common places
# for 'id', /bin/id and /usr/bin/id.
-if [ -x /bin/id ]; then
- user='char *BuildUser= "'`/bin/id`'";'
-else
- if [ -x /usr/bin/id ]; then
- user='char *BuildUser= "'`/usr/bin/id`'";'
- else
user='char *BuildUser= (char *)0;'
- fi
-fi
# try to find out the system information
-if [ -x /bin/uname ]; then
- uname='char *BuildSystem= "'`/bin/uname -a`'";'
-else
- uname='char *BuildSystem= "<unknown system>";'
-fi
+ uname='char *BuildSystem= "FreeBSD";'
echo '/* THIS FILE IS AUTOMATICALLY GENERATED */' > build.c
echo $uname >> build.c