freebsd-ports/net-mgmt/seafile-server/files/patch-common_obj-backend-fs.c
Richard Gallamore ac3636371b * Updated to 7.1.3
This minor version update no longer supports python 2.7.
The way mysql support is detected upstream has changed. Instead of patching
the configure.ac script, I used a couple hacks for this to be detected for
custom configurations. Didn't detect any issues with this method but I'm
open to change this in the future.

Added a SeaHub upgrade message to smooth out upgrading. For upgrading from 7.0.x,
if one does not clear the cache, http 500 will be returned.

The seafile_datadir no longer points to the seahub.ini, this has been changed
upstream and may cause upgrading issues if not using the default. This can
easily be changed by setting it in rc.conf.

Changes: https://download.seafile.com/published/seafile-manual/changelog/changelog-for-seafile-professional-server.md
2020-04-16 00:28:24 +00:00

20 lines
735 B
C

--- common/obj-backend-fs.c.orig 2019-12-23 10:30:49 UTC
+++ common/obj-backend-fs.c
@@ -95,7 +95,7 @@ obj_backend_fs_read (ObjBackend *bend,
static int
fsync_obj_contents (int fd)
{
-#ifdef __linux__
+#if defined(__linux__) || defined(__FreeBSD__) || defined(__DragonFly__) || defined(__NetBSD__) || defined(__OpenBSD__)
/* Some file systems may not support fsync().
* In this case, just skip the error.
*/
@@ -147,7 +147,7 @@ fsync_obj_contents (int fd)
static int
rename_and_sync (const char *tmp_path, const char *obj_path)
{
-#ifdef __linux__
+#if defined(__linux__) || defined(__FreeBSD__) || defined(__DragonFly__) || defined(__NetBSD__) || defined(__OpenBSD__)
char *parent_dir;
int ret = 0;