d32a5e2d09
-pthread. The correct sollution is to use $(LINK) which points to the used gcc compiler. Unfortunately gcc doesn't understand --whole-archive and --no-whole-archive. You have to use -Wl,-whole-archive and -Wl,-no-whole-archive instead. The following patch does this for FreeBSD, but maybe this should also be done for the generic UNX case. See http://www.openoffice.org/issues/show_bug.cgi?id=18064 for details. Obtained from Volker Quetschke
11 lines
894 B
Makefile
11 lines
894 B
Makefile
--- ../python/makefile.mk 31 Jul 2003 12:15:14 -0000 1.5.2.2
|
|
+++ ../python/makefile.mk 8 Aug 2003 15:28:45 -0000
|
|
@@ -187,7 +187,7 @@
|
|
ld -G -o $@ -u Py_Main -u Py_FrozenMain -u PyFPE_dummy $(MISC)$/build$/$(TARFILE_NAME)$/libpython$(PYMAJOR).$(PYMINOR).a -h libpython.so.$(PYMAJOR) -lm -ldl -lc -lpthread
|
|
.ELSE
|
|
.IF "$(OS)" == "FREEBSD"
|
|
- ld -shared -o $@ --whole-archive $(MISC)$/build$/$(TARFILE_NAME)$/libpython$(PYMAJOR).$(PYMINOR).a --no-whole-archive -soname libpython.so.$(PYMAJOR) -lm -lutil ${PTHREAD_LIBS}
|
|
+ $(LINK) -shared -o $@ -Wl,-whole-archive $(MISC)$/build$/$(TARFILE_NAME)$/libpython$(PYMAJOR).$(PYMINOR).a -Wl,-no-whole-archive -soname libpython.so.$(PYMAJOR) -lm -lutil ${PTHREAD_LIBS}
|
|
.ELSE
|
|
.IF "$(OS)" == "IRIX"
|
|
ld -shared -o $@ -all $(MISC)$/build$/$(TARFILE_NAME)$/libpython$(PYMAJOR).$(PYMINOR).a -notall -soname libpython.so.$(PYMAJOR) -lm -ldl -lc -lpthread
|