0e736bceef
Merge all changes from databases/redis-devel to databases/redis. <ChangeLog> Redis 3.0 release notes ======================= --[ Redis 3.0.0 ] Release date: 1 Apr 2015 >> What's new in Redis 3.0 compared to Redis 2.8? * Redis Cluster: a distributed implementation of a subset of Redis. * New "embedded string" object encoding resulting in less cache misses. Big speed gain under certain work loads. * AOF child -> parent final data transmission to minimize latency due to "last write" during AOF rewrites. * Much improved LRU approximation algorithm for keys eviction. * WAIT command to block waiting for a write to be transmitted to the specified number of slaves. * MIGRATE connection caching. Much faster keys migraitons. * MIGARTE new options COPY and REPLACE. * CLIENT PAUSE command: stop processing client requests for a specified amount of time. * BITCOUNT performance improvements. * CONFIG SET accepts memory values in different units (for example you can use "CONFIG SET maxmemory 1gb"). * Redis log format slightly changed reporting in each line the role of the instance (master/slave) or if it's a saving child log. * INCR performance improvements. >> Refactoring changes (no new features nor bug fixes) * Blocking operations full refactoring (blocked.c) * Client output buffer memory tracking refactored. </ChangeLog>
41 lines
1.3 KiB
Text
41 lines
1.3 KiB
Text
--- deps/hiredis/Makefile.orig 2014-07-29 12:17:48.000000000 +0400
|
|
+++ deps/hiredis/Makefile 2014-09-10 02:32:25.000000000 +0400
|
|
@@ -25,10 +25,10 @@
|
|
|
|
# Fallback to gcc when $CC is not in $PATH.
|
|
CC:=$(shell sh -c 'type $(CC) >/dev/null 2>/dev/null && echo $(CC) || echo gcc')
|
|
-OPTIMIZATION?=-O3
|
|
+#OPTIMIZATION?=-O3
|
|
WARNINGS=-Wall -W -Wstrict-prototypes -Wwrite-strings
|
|
-DEBUG?= -g -ggdb
|
|
-REAL_CFLAGS=$(OPTIMIZATION) -fPIC $(CFLAGS) $(WARNINGS) $(DEBUG) $(ARCH)
|
|
+#DEBUG?= -g -ggdb
|
|
+REAL_CFLAGS=$(OPTIMIZATION) -fPIC $(CFLAGS) $(WARNINGS) $(DEBUG)
|
|
REAL_LDFLAGS=$(LDFLAGS) $(ARCH)
|
|
|
|
DYLIBSUFFIX=so
|
|
@@ -47,6 +47,15 @@
|
|
DYLIB_MAKE_CMD=$(CC) -G -o $(DYLIBNAME) -h $(DYLIB_MINOR_NAME) $(LDFLAGS)
|
|
INSTALL= cp -r
|
|
endif
|
|
+ifeq ($(uname_S),FreeBSD)
|
|
+ CFLAGS?=$(CFLAGS)
|
|
+ CCLINK?=-pthread
|
|
+ LDFLAGS?=-L. -Wl,-rpath,.
|
|
+ DYLIBNAME?=libhiredis.so
|
|
+ DYLIB_MAKE_CMD?=$(CC) -o ${DYLIBNAME} ${OBJ}
|
|
+ STLIBNAME?=libhiredis.a
|
|
+ STLIB_MAKE_CMD?=ar rcs ${STLIBNAME} ${OBJ}
|
|
+endif
|
|
ifeq ($(uname_S),Darwin)
|
|
DYLIBSUFFIX=dylib
|
|
DYLIB_MINOR_NAME=$(LIBNAME).$(HIREDIS_MAJOR).$(HIREDIS_MINOR).$(DYLIBSUFFIX)
|
|
@@ -124,7 +133,7 @@
|
|
$(CC) -MM *.c
|
|
|
|
# Installation related variables and target
|
|
-PREFIX?=/usr/local
|
|
+PREFIX?=${PREFIX}
|
|
INSTALL_INCLUDE_PATH= $(PREFIX)/include/hiredis
|
|
INSTALL_LIBRARY_PATH= $(PREFIX)/lib
|
|
|