freebsd-ports/net-im/psi/files/patch-src_sxe_CMakeLists.txt
Tobias C. Berner 5936b0b76e net-im/psi: Add patches to fix build
Add dependencies on the ui-gen target, this
should fix the race condition during the build.

PR:		229854
Reported by:	antoine
2018-07-20 20:46:10 +00:00

8 lines
358 B
Text

--- src/sxe/CMakeLists.txt.orig 2018-07-20 20:15:10 UTC
+++ src/sxe/CMakeLists.txt
@@ -34,4 +34,5 @@ set(PLAIN_HEADERS
qt_wrap_cpp(MOC_SOURCES ${HEADERS})
add_library(sxe STATIC ${HEADERS} ${MOC_SOURCES} ${PLAIN_SOURCES} ${PLAIN_HEADERS})
+add_dependencies(sxe build_ui_files)
target_link_libraries(sxe ${QT_LIBRARIES} ${iris_LIB} libpsi_tools widgets)