. lang/python27: 2.7.3 -> 2.7.5 . lang/python32: 3.2.3 -> 3.2.4 . lang/python33: 3.3.0 -> 3.3.1 - update Mk/bsd.python.mk with new versions - mark lang/python26 and lang/python31 as deprecated (set them to upstream EoL dates) - update docs (lang/python-doc-html) - align databases/py-bsddb patch for python27 - most of it was applied upstream. Raise BDB version to 4.3 atleast, according to upstream requirements. Many thanks to Martin (miwi) for his time on this update. PR: 178506 Submitted by: rm (myself) Exp-run by: portmgr (miwi) - revert erroneous threads patch in lang/python26 and lang/python27, that was added after ports/131080. It was rejected upstream, because it's not actually a bug, but misuse. Gabor Pali (pgj) in collaboration with Kubilay Kocak (koobs) did an independent investigation regard the issue. See here for details: http://lists.freebsd.org/pipermail/freebsd-python/2013-April/005376.html PR: 153167 Submitted by: Duncan Findlay <duncan@duncf.ca> Reported by: pgj/koobs (at python@ ML) Exp-run by: portmgr (miwi)
14 lines
436 B
Text
14 lines
436 B
Text
--- ./Makefile.pre.in.orig 2013-04-06 18:02:34.000000000 +0400
|
|
+++ ./Makefile.pre.in 2013-04-07 22:30:19.000000000 +0400
|
|
@@ -281,9 +281,9 @@
|
|
|
|
##########################################################################
|
|
# AST
|
|
-AST_H_DIR= Include
|
|
+AST_H_DIR= $(srcdir)/Include
|
|
AST_H= $(AST_H_DIR)/Python-ast.h
|
|
-AST_C_DIR= Python
|
|
+AST_C_DIR= $(srcdir)/Python
|
|
AST_C= $(AST_C_DIR)/Python-ast.c
|
|
AST_ASDL= $(srcdir)/Parser/Python.asdl
|
|
|