- Add '-fPIC' compiler flag to a source file that is shared between both executables and libraries [1]. Reported by: pointyhat [1]
14 lines
283 B
Makefile
14 lines
283 B
Makefile
--- build/post.mk.orig Sun Feb 4 19:51:48 2007
|
|
+++ build/post.mk Sun Feb 4 19:52:55 2007
|
|
@@ -33,7 +33,10 @@
|
|
|
|
%.o: %.c
|
|
$(CC) $(CFLAGS) -c -o $@ $<
|
|
-
|
|
+
|
|
+q_shared.o: q_shared.c
|
|
+ $(CC) $(CFLAGS) -fPIC -c -o $@ $<
|
|
+
|
|
%.o: %.s
|
|
$(CC) $(CFLAGS) -x assembler-with-cpp -c -o $@ $<
|
|
|