freebsd-ports/games/battalion/files/patch-aa
Donald Burr 89d79ff9c8 PR: ports/6985
Submitted by:	Andrey Zakhvatov <andy@icc.surw.chel.su>
Import of new port games/battalion, a "big monster stomps around
destroying buildings and army vehicles" type game.
1998-07-14 01:15:18 +00:00

61 lines
1.7 KiB
Text

--- Makefile Thu Jan 16 16:31:58 1997
+++ /home/andy/tmp/wrk/Makefile Sun May 17 15:46:52 1998
@@ -23,7 +23,7 @@
# (the program should compile with no warning messages - if you
# see a warning message please let me know about it)
# ------------------------------------------------------------
-CC = CC
+#CC = CC
# STEP 2: IF YOU WANT TO COMPILE WITH THE MESA LIBRARIES THEN
@@ -39,7 +39,7 @@
# ------------------------------------------------------------
#GLIB = -lMesaGL -lMesaGLU
# or
-GLIB = -lGL -lGLU
+GLIB = -lMesaGL -lMesaGLU
# STEP 4: CHOOSE WHICH HARDWARE / OS YOU ARE RUNNING
@@ -51,9 +51,9 @@
# with the other Makefile.)
#
# ------------------------------------------------------------
-OS = -DSGIVERSION
+#OS = -DSGIVERSION
# or
-#OS = -DSUNVERSION
+OS = -DSUNVERSION
# or
#OS = -DLINUXVERSION
# or
@@ -77,8 +77,8 @@
# in audio.c then everything works fine.
#
# ------------------------------------------------------------
-AUDIOLIB = -laudio -laudiofile
-AUDIODEF = -DSGIAUDIO
+#AUDIOLIB = -laudio -laudiofile
+#AUDIODEF = -DSGIAUDIO
# STEP 6: IF YOU ARE COMPILING FOR A SUN AND WANT (RUDIMENTARY)
@@ -91,7 +91,7 @@
# STEP 7: CHOOSE ANY OPTIMIZATIONS OR ADD ANY SPECIAL INCLUSIONS
# ------------------------------------------------------------
-CFLAGS = -O -I/usr/local/X11/include -I/usr/demo/SOUND/ -I./.
+CFLAGS+= -I${X11BASE}/include
# STEP 8: ADD ANY SPECIAL LIBRARY PATHS
@@ -106,7 +106,7 @@
TARGET = battalion
OBJ = battalion.o audio.o net.o gprim.o graphics.o objects.o text.o update.o tk.o font.o
-LIBS = -L./. -L/usr/X11R6/lib -lm -lX11 -lXext
+LIBS = -L./. -L/usr/X11R6/lib -lm -lX11 -lXext -lcompat
all: $(TARGET)