41e56db75f
Regenerate the patches to make portlint(1) happier. <ChangeLog> Upgrade urgency CRITICAL: Only in case of exposed instances to untrusted users. This Redis release, 5.0.6, is a bugfix and enhancement release. The most important bugfix is a corruption related to the HyperLogLog. A malformed HyperLogLog string could cause an invalid access to the memory. At a first glance the vulnerability appears to be not exploitable but just a DoS. The way to trigger the issue is complex, we'll not provide any information about how to do that for the users safety. Other significant changes in this release: * New modules APIs merged from Redis unstable to Redis 5. * Some memory optimization related to objects creation. * Fixes to flushSlaveOutputBuffer() that make sure that SHUTDOWN will transfer pending buffers to replicas. </ChangeLog>
20 lines
855 B
Text
20 lines
855 B
Text
--- deps/Makefile.orig 2019-09-25 10:40:18 UTC
|
|
+++ deps/Makefile
|
|
@@ -58,7 +58,7 @@ ifeq ($(uname_S),SunOS)
|
|
LUA_CFLAGS= -D__C99FEATURES__=1
|
|
endif
|
|
|
|
-LUA_CFLAGS+= -O2 -Wall -DLUA_ANSI -DENABLE_CJSON_GLOBAL -DREDIS_STATIC='' $(CFLAGS)
|
|
+LUA_CFLAGS+= -Wall -DLUA_ANSI -DENABLE_CJSON_GLOBAL -DREDIS_STATIC='' $(CFLAGS)
|
|
LUA_LDFLAGS+= $(LDFLAGS)
|
|
# lua's Makefile defines AR="ar rcu", which is unusual, and makes it more
|
|
# challenging to cross-compile lua (and redis). These defines make it easier
|
|
@@ -68,7 +68,7 @@ ARFLAGS=rcu
|
|
|
|
lua: .make-prerequisites
|
|
@printf '%b %b\n' $(MAKECOLOR)MAKE$(ENDCOLOR) $(BINCOLOR)$@$(ENDCOLOR)
|
|
- cd lua/src && $(MAKE) all CFLAGS="$(LUA_CFLAGS)" MYLDFLAGS="$(LUA_LDFLAGS)" AR="$(AR) $(ARFLAGS)"
|
|
+ cd lua/src && $(MAKE) all CC="$(CC)" CFLAGS="$(LUA_CFLAGS)" MYLDFLAGS="$(LUA_LDFLAGS)" AR="$(AR) $(ARFLAGS)"
|
|
|
|
.PHONY: lua
|
|
|