freebsd-ports/biology/bamutil/files/patch-libStatGen_Makefiles_Makefile.lib
Jason W. Bacon cdf2ff2f68 biology/bamutil: Utilities for working with SAM/BAM files
Utilities for working on SAM/BAM files from The Center for Statistical
Genetics at the University of Michigan School of Public Health.  It
includes numerous functions such as splitting, merging, trimming reads,
filtering, validation, diff, etc.
2021-10-12 11:40:35 -05:00

17 lines
559 B
Text

--- libStatGen/Makefiles/Makefile.lib.orig 2021-10-12 15:28:34 UTC
+++ libStatGen/Makefiles/Makefile.lib
@@ -34,11 +34,11 @@ profile: $(STAT_GEN_LIB_PROFILE)
# To build the library, build the objects
# Then add them to the library
$(STAT_GEN_LIB_OPT): $(OBJECTS_OPT)
- ar -cru $@ $(OBJECTS_OPT)
+ ar -cr $@ $(OBJECTS_OPT)
$(STAT_GEN_LIB_DEBUG): $(OBJECTS_DEBUG)
- ar -cru $@ $(OBJECTS_DEBUG)
+ ar -cr $@ $(OBJECTS_DEBUG)
$(STAT_GEN_LIB_PROFILE): $(OBJECTS_PROFILE)
- ar -cru $@ $(OBJECTS_PROFILE)
+ ar -cr $@ $(OBJECTS_PROFILE)
UNAME=$(shell uname)