607eebc44b
This version fixes CVE-2013-2877. Add upstream patch for CVE-2014-0191. CVE's Reported by: Akinori MUSHA <knu@iDaemons.org> Obtained from: GNOME dev repo [1], libxml2 upstream [2] MFH: 2014Q2
142 lines
4.4 KiB
Python
142 lines
4.4 KiB
Python
--- python/setup.py.in.orig 2014-03-24 21:27:16.000000000 +0100
|
|
+++ python/setup.py.in 2014-03-24 21:31:10.000000000 +0100
|
|
@@ -67,7 +67,7 @@
|
|
for dir in includes_dir:
|
|
if not missing(dir + "/libxml2/libxml/tree.h"):
|
|
xml_includes=dir + "/libxml2"
|
|
- break;
|
|
+ break;
|
|
|
|
if xml_includes == "":
|
|
print("failed to find headers for libxml2: update includes_dir")
|
|
@@ -77,7 +77,7 @@
|
|
for dir in includes_dir:
|
|
if not missing(dir + "/iconv.h"):
|
|
iconv_includes=dir
|
|
- break;
|
|
+ break;
|
|
|
|
if iconv_includes == "":
|
|
print("failed to find headers for libiconv: update includes_dir")
|
|
@@ -90,22 +90,22 @@
|
|
|
|
xml_files = ["libxml2-api.xml", "libxml2-python-api.xml",
|
|
"libxml.c", "libxml.py", "libxml_wrap.h", "types.c",
|
|
- "xmlgenerator.py", "README", "TODO", "drv_libxml2.py"]
|
|
+ "xmlgenerator.py", "README", "TODO", "drv_libxml2.py"]
|
|
|
|
xslt_files = ["libxslt-api.xml", "libxslt-python-api.xml",
|
|
"libxslt.c", "libxsl.py", "libxslt_wrap.h",
|
|
- "xsltgenerator.py"]
|
|
+ "xsltgenerator.py"]
|
|
|
|
if missing("libxml2-py.c") or missing("libxml2.py"):
|
|
try:
|
|
- try:
|
|
- import xmlgenerator
|
|
- except:
|
|
- import generator
|
|
+ try:
|
|
+ import xmlgenerator
|
|
+ except:
|
|
+ import generator
|
|
except:
|
|
- print("failed to find and generate stubs for libxml2, aborting ...")
|
|
- print(sys.exc_info()[0], sys.exc_info()[1])
|
|
- sys.exit(1)
|
|
+ print("failed to find and generate stubs for libxml2, aborting ...")
|
|
+ print(sys.exc_info()[0], sys.exc_info()[1])
|
|
+ sys.exit(1)
|
|
|
|
head = open("libxml.py", "r")
|
|
generated = open("libxml2class.py", "r")
|
|
@@ -116,7 +116,7 @@
|
|
else:
|
|
result.write(line)
|
|
for line in generated.readlines():
|
|
- result.write(line)
|
|
+ result.write(line)
|
|
head.close()
|
|
generated.close()
|
|
result.close()
|
|
@@ -126,39 +126,39 @@
|
|
if missing("xsltgenerator.py") or missing("libxslt-api.xml"):
|
|
print("libxslt stub generator not found, libxslt not built")
|
|
else:
|
|
- try:
|
|
- import xsltgenerator
|
|
- except:
|
|
- print("failed to generate stubs for libxslt, aborting ...")
|
|
- print(sys.exc_info()[0], sys.exc_info()[1])
|
|
- else:
|
|
- head = open("libxsl.py", "r")
|
|
- generated = open("libxsltclass.py", "r")
|
|
- result = open("libxslt.py", "w")
|
|
- for line in head.readlines():
|
|
+ try:
|
|
+ import xsltgenerator
|
|
+ except:
|
|
+ print("failed to generate stubs for libxslt, aborting ...")
|
|
+ print(sys.exc_info()[0], sys.exc_info()[1])
|
|
+ else:
|
|
+ head = open("libxsl.py", "r")
|
|
+ generated = open("libxsltclass.py", "r")
|
|
+ result = open("libxslt.py", "w")
|
|
+ for line in head.readlines():
|
|
if WITHDLLS:
|
|
result.write(altImport(line))
|
|
else:
|
|
result.write(line)
|
|
- for line in generated.readlines():
|
|
- result.write(line)
|
|
- head.close()
|
|
- generated.close()
|
|
- result.close()
|
|
- with_xslt=1
|
|
+ for line in generated.readlines():
|
|
+ result.write(line)
|
|
+ head.close()
|
|
+ generated.close()
|
|
+ result.close()
|
|
+ with_xslt=1
|
|
else:
|
|
with_xslt=1
|
|
|
|
if with_xslt == 1:
|
|
xslt_includes=""
|
|
for dir in includes_dir:
|
|
- if not missing(dir + "/libxslt/xsltconfig.h"):
|
|
- xslt_includes=dir + "/libxslt"
|
|
- break;
|
|
+ if not missing(dir + "/libxslt/xsltconfig.h"):
|
|
+ xslt_includes=dir + "/libxslt"
|
|
+ break;
|
|
|
|
if xslt_includes == "":
|
|
- print("failed to find headers for libxslt: update includes_dir")
|
|
- with_xslt = 0
|
|
+ print("failed to find headers for libxslt: update includes_dir")
|
|
+ with_xslt = 0
|
|
|
|
|
|
descr = "libxml2 package"
|
|
@@ -198,7 +198,7 @@
|
|
libraries=libs, define_macros=macros)]
|
|
if with_xslt == 1:
|
|
extens.append(Extension('libxsltmod', xslt_c_files, include_dirs=includes,
|
|
- library_dirs=libdirs,
|
|
+ library_dirs=libdirs,
|
|
libraries=libs, define_macros=macros))
|
|
|
|
if missing("MANIFEST"):
|
|
@@ -208,8 +208,8 @@
|
|
for file in xml_files:
|
|
manifest.write(file + "\n")
|
|
if with_xslt == 1:
|
|
- for file in xslt_files:
|
|
- manifest.write(file + "\n")
|
|
+ for file in xslt_files:
|
|
+ manifest.write(file + "\n")
|
|
manifest.close()
|
|
|
|
if WITHDLLS:
|