freebsd-ports/audio/sdl2_mixer/files/patch-CMakeLists.txt
2022-07-21 15:40:40 +03:00

29 lines
1 KiB
Text

All these changes were upstreamed after 2.6.1
--- CMakeLists.txt.orig 2022-07-12 20:19:55 UTC
+++ CMakeLists.txt
@@ -294,14 +294,14 @@ if(SDL2MIXER_CMD)
target_compile_definitions(SDL2_mixer PRIVATE MUSIC_CMD)
set(fork_found OFF)
if(NOT fork_found)
- check_symbol_exists(fork sys/unistd.h HAVE_FORK)
+ check_symbol_exists(fork unistd.h HAVE_FORK)
if(HAVE_FORK)
set(fork_found ON)
target_compile_definitions(SDL2_mixer PRIVATE HAVE_FORK)
endif()
endif()
if(NOT fork_found)
- check_symbol_exists(fork sys/unistd.h HAVE_VFORK)
+ check_symbol_exists(fork unistd.h HAVE_VFORK)
if(HAVE_VFORK)
set(fork_found ON)
target_compile_definitions(SDL2_mixer PRIVATE HAVE_VFORK)
@@ -528,7 +528,7 @@ if(SDL2MIXER_FLAC_LIBFLAC)
add_dependencies(SDL2_mixer FLAC)
endif()
else()
- target_link_libraries(SDL2_mixer PRIVATE FLAC)
+ target_link_libraries(SDL2_mixer PRIVATE FLAC::FLAC)
endif()
endif()