freebsd-ports/net/mcl/files/patch-fcast-Makefile
Bruce M Simpson 7ab4a1fe58 Add mcl 2.99,
implementation of the ALC and NORM Reliable Multicast
Protocols.

PR:		58728
Submitted by:	past@noc.ntua.gr
2003-11-14 16:33:33 +00:00

28 lines
760 B
Text

--- fcast/Makefile.orig Tue Jul 22 19:43:25 2003
+++ fcast/Makefile Wed Oct 15 17:20:46 2003
@@ -39,6 +39,14 @@
endif
+ifeq (${OS},freebsd)
+ # FreeBSD version
+ #
+ BINDIR = ../bin/freebsd
+ LDPC_BINDIR = ../../ldpc/bin/freebsd
+ LIBRARIES = -lm -pthread
+endif
+
###### Other variables ######
@@ -76,8 +84,8 @@
# codec in use: if LDPC is used, then add the libbdpc.a library.
# If only RSE is used and if you don't have the LDPC archive, then
# remove the libbdpc.a library.
-#alc: MCL_LIBRARY = ${BINDIR}/libmclalc.a
-alc: MCL_LIBRARY = ${BINDIR}/libmclalc.a ${LDPC_BINDIR}/libldpc.a
+alc: MCL_LIBRARY = ${BINDIR}/libmclalc.a
+#alc: MCL_LIBRARY = ${BINDIR}/libmclalc.a ${LDPC_BINDIR}/libldpc.a
alc: TARGET_FCAST = ${BINDIR}/fcast
#alc: all