freebsd-ports/japanese/p5-PDFJ/files/patch-Object.pm
Jun Kuriyama f3162438a7 Make this module "perl -w" friendly.
Respect $PKGNAMEPREFIX in ../Makefile.inc.
2002-10-24 07:46:28 +00:00

10 lines
370 B
Perl

--- PDFJ/Object.pm.orig Thu Oct 24 16:32:34 2002
+++ PDFJ/Object.pm Thu Oct 24 16:37:38 2002
@@ -133,6 +133,7 @@
sub makeoutput {
my $self = shift;
+ $self->{outputtype} = "" if (not defined $self->{outputtype});
if( $self->{outputtype} !~ /^(literal|hex|hexliteral)$/ ) {
$self->{outputtype} =
$self->{value} =~ /[\x80-\xff]/ ? 'hex' : 'literal';