cbc10a11c1
Unify the variant ports and make them slave ports of the master port, nethack34. Unbreak nethack34-gnome. PR: ports/36576, ports/36880 Submitted by: KATO Tsuguru <tkato@prontomail.com>, Jan Stocker <Jan.Stocker@t-online.de> (MAINTAINER of -gnome)
41 lines
1.4 KiB
Text
41 lines
1.4 KiB
Text
--- sys/unix/Makefile.doc.orig Sat Jan 15 05:49:48 2000
|
|
+++ sys/unix/Makefile.doc Sat Aug 11 11:08:33 2001
|
|
@@ -34,15 +34,15 @@
|
|
|
|
|
|
GAME = nethack
|
|
-MANDIR = /usr/man/man6
|
|
+MANDIR = ${PREFIX}/man/man
|
|
MANEXT = 6
|
|
|
|
# manual installation for most BSD-style systems
|
|
-GAMEMANCREATE = cp nethack.6
|
|
-LEVMANCREATE = cp lev_comp.6
|
|
-DGNMANCREATE = cp dgn_comp.6
|
|
-RCVRMANCREATE = cp recover.6
|
|
-DLBMANCREATE = cp dlb.6
|
|
+GAMEMANCREATE = ${BSD_INSTALL_MAN} nethack.6
|
|
+LEVMANCREATE = ${BSD_INSTALL_MAN} lev_comp.6
|
|
+DGNMANCREATE = ${BSD_INSTALL_MAN} dgn_comp.6
|
|
+RCVRMANCREATE = ${BSD_INSTALL_MAN} recover.6
|
|
+DLBMANCREATE = ${BSD_INSTALL_MAN} dlb.6
|
|
# manual installation for most SYSV-style systems
|
|
# GAMEMANCREATE = nroff -man nethack.6 >
|
|
# LEVMANCREATE = nroff -man lev_comp.6 >
|
|
@@ -51,11 +51,11 @@
|
|
# DLBMANCREATE = nroff -man dlb.6 >
|
|
|
|
manpages:
|
|
- -$(GAMEMANCREATE) $(MANDIR)/$(GAME).$(MANEXT)
|
|
- -$(LEVMANCREATE) $(MANDIR)/lev_comp.$(MANEXT)
|
|
- -$(DGNMANCREATE) $(MANDIR)/dgn_comp.$(MANEXT)
|
|
- -$(RCVRMANCREATE) $(MANDIR)/recover.$(MANEXT)
|
|
- -$(DLBMANCREATE) $(MANDIR)/dlb.$(MANEXT)
|
|
+ -$(GAMEMANCREATE) $(MANDIR)$(MANEXT)/$(GAME).$(MANEXT)
|
|
+ -$(LEVMANCREATE) $(MANDIR)$(MANEXT)/lev_comp.$(MANEXT)
|
|
+ -$(DGNMANCREATE) $(MANDIR)$(MANEXT)/dgn_comp.$(MANEXT)
|
|
+ -$(RCVRMANCREATE) $(MANDIR)$(MANEXT)/recover.$(MANEXT)
|
|
+ -$(DLBMANCREATE) $(MANDIR)$(MANEXT)/dlb.$(MANEXT)
|
|
|
|
# manual creation for distribution
|
|
DISTRIB = Guidebook.txt nethack.txt lev_comp.txt dgn_comp.txt recover.txt dlb.txt
|