- Update amd64 host bsd-user linker script to fix build on -current/amd64. [1] - Some updates to the pkg-message. PR: ports/155558 [1] Submitted by: Garrett Cooper <yanegomi@gmail.com> [1]
36 lines
1.2 KiB
Text
36 lines
1.2 KiB
Text
Index: qemu/Makefile
|
|
@@ -29,7 +29,11 @@ $(call set-vpath, $(SRC_PATH):$(SRC_PATH
|
|
LIBS+=-lz $(LIBS_TOOLS)
|
|
|
|
ifdef BUILD_DOCS
|
|
+ifdef NOPORTDOCS
|
|
+DOCS=qemu.1 qemu-img.1 qemu-nbd.8
|
|
+else
|
|
DOCS=qemu-doc.html qemu-tech.html qemu.1 qemu-img.1 qemu-nbd.8 QMP/qmp-commands.txt
|
|
+endif
|
|
else
|
|
DOCS=
|
|
endif
|
|
@@ -169,8 +173,10 @@ BLOBS=
|
|
endif
|
|
|
|
install-doc: $(DOCS)
|
|
+ifndef NOPORTDOCS
|
|
$(INSTALL_DIR) "$(DESTDIR)$(docdir)"
|
|
$(INSTALL_DATA) qemu-doc.html qemu-tech.html "$(DESTDIR)$(docdir)"
|
|
+endif
|
|
ifdef CONFIG_POSIX
|
|
$(INSTALL_DIR) "$(DESTDIR)$(mandir)/man1"
|
|
$(INSTALL_DATA) qemu.1 qemu-img.1 "$(DESTDIR)$(mandir)/man1"
|
|
@@ -180,7 +186,10 @@ endif
|
|
|
|
install-sysconfig:
|
|
$(INSTALL_DIR) "$(DESTDIR)$(sysconfdir)/qemu"
|
|
- $(INSTALL_DATA) $(SRC_PATH)/sysconfigs/target/target-x86_64.conf "$(DESTDIR)$(sysconfdir)/qemu"
|
|
+ $(INSTALL_DATA) $(SRC_PATH)/sysconfigs/target/target-x86_64.conf "$(DESTDIR)$(sysconfdir)/qemu/target-x86_64.conf.sample"
|
|
+ if [ ! -f "$(sysconfdir)/qemu/target-x86_64.conf" ]; then \
|
|
+ $(INSTALL_DATA) $(SRC_PATH)/sysconfigs/target/target-x86_64.conf "$(sysconfdir)/qemu"; \
|
|
+ fi
|
|
|
|
install: all $(if $(BUILD_DOCS),install-doc) install-sysconfig
|
|
$(INSTALL_DIR) "$(DESTDIR)$(bindir)"
|