freebsd-ports/misc/openvdb/files/patch-CMakeLists.txt
Yuri Victorovich 24d1604d7d misc/openvdb: Add TOOLS and DOCS options
Submitted by:	Shane Ambler <FreeBSD@shaneware.biz> (via e-mail)
2019-05-18 05:30:38 +00:00

20 lines
711 B
Text

--- CMakeLists.txt.orig 2019-05-07 20:58:35 UTC
+++ CMakeLists.txt
@@ -177,7 +177,7 @@ if(NOT DISABLE_DEPENDENCY_VERSION_CHECKS)
set(MINIMUM_ZLIB_VERSION 1.2.7)
set(MINIMUM_TBB_VERSION 4.4)
- set(MINIMUM_PYTHON_VERSION 2.7)
+ set(MINIMUM_PYTHON_VERSION ${FREEBSD_PYTHON_VER})
set(MINIMUM_NUMPY_VERSION 1.9.2)
set(MINIMUM_CPPUNIT_VERSION 1.10)
@@ -271,7 +271,7 @@ if(OPENVDB_BUILD_DOCS)
COMMENT "Generating API documentation with Doxygen" VERBATIM
)
- install(DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/openvdb/doc/html DESTINATION docs)
+ install(DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/openvdb/doc/html DESTINATION share/doc/openvdb)
endif()
# Early exit if there's nothing to build