freebsd-ports/graphics/svgalib/files/patch-ab
Maxim Sobolev c01aa3135c Add svgalib - a *native* port of well-knows Linux console graphics library.
Please note, that it's a work in progress, so some features doesn't work (for
example mouse support). However, the functionality already present is
sufficient to run some of the popular apps (quakeforge for example).

I tested it on ATI Mach64 and C&T55554 adapters.
2000-08-25 09:08:01 +00:00

37 lines
1.1 KiB
Text

--- src/Makefile.orig Thu Jul 6 19:10:58 2000
+++ src/Makefile Fri Aug 25 05:15:15 2000
@@ -14,7 +14,7 @@
# Compiler Section (overrides Makefile.cfg)
#----------------------------------------------------------------------
-INCLUDES += -I$(srcdir)/src
+INCLUDES += -I$(srcdir)/src -I$(srcdir)/src/config
#----------------------------------------------------------------------
# Rules Section
@@ -361,6 +361,7 @@
libvga.so.$(VERSION): $(ALLOBJS)
$(CC) -s -shared -Wl,-soname,libvga.so.$(MAJOR_VER) \
-o libvga.so.$(VERSION) $(ALLOBJS) -lm
+ /bin/ln -sf libvga.so.$(VERSION) libvga.so
$(sharedlibdir)/libvga.so.$(VERSION): libvga.so.$(VERSION)
$(INSTALL_PROGRAM) $< $(sharedlibdir)/$<
@@ -375,7 +376,7 @@
$(AR) rcs libvga.a $(ALLOBJS)
libvgagl.a: FORCE
- make -f $(srcdir)/gl/Makefile $@ srcdir="$(srcdir)" DLLFLAGS="$(DLLFLAGS)"
+ $(MAKE) -f $(srcdir)/gl/Makefile $@ srcdir="$(srcdir)" DLLFLAGS="$(DLLFLAGS)"
vga.o: vga.c
$(CC) $(CFLAGS) $(VGA_DEFINES) -c -o $@ $<
@@ -397,7 +398,7 @@
dep:
rm -f .depend.src
- make .depend.src
+ $(MAKE) .depend.src
.depend.src:
echo '# Module dependencies' >>.depend.src