freebsd-ports/www/mod_python3/files/patch-configure
Hye-Shik Chang 6bd26f60ea Update to 3.2.10 which is compatible with Apache 2.2 also.
PR:		100208
Submitted by:	Mark Evenson <mark.evenson@gmx.at>,
		Nick Pavlica <znpmail@yahoo.com>,
		Nikolai Nespor <nikolai.nespor@utanet.at>
2006-08-09 01:10:14 +00:00

11 lines
733 B
Text

--- configure.orig Sat Aug 5 09:51:23 2006
+++ configure Sat Aug 5 09:57:47 2006
@@ -2899,7 +2899,7 @@
PyLIBP=${PY_STD_LIB}
PyLIBPL=${PyLIBP}/config
PyPYTHONLIBS=${PyLIBPL}/libpython${PyVERSION}.a
-PyLIBS=`grep "^LIB[SMC]=" ${PyLIBPL}/Makefile | cut -f2 -d= | tr '\011\012\015' ' '`
+PyLIBS=`ldd $PYTHON_BIN | sed -n 's,^.* => [^ ]*/lib\(.*\)\.so[^ ]* \((.*)\),-l\1,p' | grep -v '^-lc$' | xargs echo`
PyMODLIBS=`grep "^LOCALMODLIBS=" ${PyLIBPL}/Makefile | cut -f2 -d= | tr '\011\012\015' ' '`
PyFRAMEWORK=`grep "^PYTHONFRAMEWORK=" ${PyLIBPL}/Makefile | cut -f2 -d= | tr '\011\012\015' ' '`
PyFRAMEWORKDIR=`grep "^PYTHONFRAMEWORKDIR=" ${PyLIBPL}/Makefile | cut -f2 -d= | tr '\011\012\015' ' ' | awk '{print $1}'`