The orignal port only ran on i386, since there were some 64bit conversion problems. The included tar file replaces the compete devel/cocktail tree currently in the ports tree. (lots of patches!) PR: ports/71940 Submitted by: Willem Jan Withagen <wjw@withagen.nl>
76 lines
1.6 KiB
Text
76 lines
1.6 KiB
Text
--- /usr/ports/devel/cocktail/work/cocktail-9309//./front/m2c/Makefile Tue Feb 15 14:23:22 1994
|
|
+++ ./front/m2c/Makefile Thu Aug 5 18:49:00 2004
|
|
@@ -1,35 +1,33 @@
|
|
-LIB = $(HOME)/lib
|
|
-OPT = -O
|
|
-CC = cc
|
|
|
|
- # C library (reuse)
|
|
-REUSE = ../../reuse/m2c
|
|
+.include "../../Makefile.inc"
|
|
|
|
- # C libraries
|
|
-CLIBS = $(REUSE)/libreuse.a
|
|
-
|
|
- # options for C compiler
|
|
-CFLAGS = -w -I$(REUSE) $(OPT)
|
|
-
|
|
-M2FLAGS = -c
|
|
+ROOTDIR = ../..
|
|
+CFLAGS += -I$(INCDIR)
|
|
+CLIBS += $(REUSELIB)
|
|
|
|
OBJS = Actions.o Character.o Checks.o Errors.o Limits.o \
|
|
- Listing.o Oper.o Pars.o Parser.o Path.o Rules.o Scanner.o \
|
|
+ Listing.o Oper.o Parser.o Path.o Rules.o Scanner.o \
|
|
SysError.o TokenTab.o Tokens.o WriteTok.o
|
|
|
|
libfront.a : $(OBJS)
|
|
ar ruc libfront.a $(OBJS)
|
|
ranlib libfront.a
|
|
|
|
-install: ErrorTab libfront.a $(LIB)/lalr
|
|
- cp ErrorTab $(LIB)/lalr
|
|
- chmod a+r $(LIB)/lalr/ErrorTab
|
|
+install: ErrorTab libfront.a $(DESTLIB)/lalr
|
|
+ cp ErrorTab $(DESTLIB)/lalr
|
|
+ chmod a+r $(DESTLIB)/lalr/ErrorTab
|
|
|
|
# installation directories
|
|
|
|
-$(LIB)/lalr: $(LIB)
|
|
- sh -c "if test ! -d $(LIB)/lalr; then mkdir -p $(LIB)/lalr; else true; fi"
|
|
+$(DESTLIB)/lalr: $(DESTLIB)
|
|
+ sh -c "if test ! -d $(DESTLIB)/lalr; then mkdir -p $(DESTLIB)/lalr; else true; fi"
|
|
+
|
|
+test: Pars
|
|
|
|
+clean:
|
|
+ -rm -f $(STDCLEAN)
|
|
+ -rm -f *.o
|
|
+ -rm -f libfront.a Pars
|
|
|
|
# HEAD
|
|
|
|
@@ -193,21 +191,3 @@
|
|
Character.o \
|
|
$(CLIBS)
|
|
|
|
-# TAIL
|
|
-
|
|
-clean :
|
|
- rm -f core *.o
|
|
-
|
|
-CLEAN :
|
|
- rm -f core *.o libfront.a
|
|
-
|
|
-.SUFFIXES: .md .mi .h .c .o
|
|
-
|
|
-.mi.c:
|
|
- mtc2 $(M2FLAGS) $*.mi;
|
|
-
|
|
-.md.h:
|
|
- mtc2 $(M2FLAGS) $*.md;
|
|
-
|
|
-.c.o:
|
|
- $(CC) $(CFLAGS) -c $*.c
|