- Add RESTRICTED (licensing issues). - Install stuff in standard places. - Install examples. - Install readmes/licenses. - Respect NOPORTDOCS. - New MAINTAINER. PR: ports/62704 Submitted by: debios@diku.dk
24 lines
633 B
Text
24 lines
633 B
Text
--- dynlibs/interface/Makefile.orig Tue Mar 14 16:40:47 2000
|
|
+++ dynlibs/interface/Makefile Fri Feb 6 13:15:42 2004
|
|
@@ -1,17 +1,15 @@
|
|
# Makefile for Moscow ML dynamic libraries: the interface example
|
|
|
|
-include ../../Makefile.inc
|
|
-
|
|
-OPTS=-fno-defer-pop
|
|
-CFLAGS=-Dunix -O2 $(OPTS) $(ADDDYNLIBCFLAGS) -I$(INCDIR)
|
|
+CFLAGS += -Dunix -fno-defer-pop -fPIC
|
|
+INC += -I/usr/local/include/mosml
|
|
|
|
all: libcside.so
|
|
|
|
cside.o: cside.c
|
|
- $(CC) $(CFLAGS) -c -o cside.o cside.c
|
|
+ $(CC) $(CFLAGS) $(INC) -c -o cside.o cside.c
|
|
|
|
libcside.so: cside.o
|
|
- $(DYNLD) -o libcside.so cside.o
|
|
+ $(LD) -shared -o libcside.so cside.o
|
|
|
|
clean:
|
|
rm -f *.o
|