2a685ab209
fastparquet is a python implementation of the parquet format, aiming integrate into python-based big data work-flows. It is used implicitly by the projects Dask, Pandas and intake-parquet. We offer a high degree of support for the features of the parquet format, and very competitive performance, in a small install size and codebase.
20 lines
607 B
Python
20 lines
607 B
Python
--- setup.py.orig 2022-11-18 01:33:09 UTC
|
|
+++ setup.py
|
|
@@ -44,7 +44,6 @@ else:
|
|
extra = {'ext_modules': cythonize(modules, language_level=3)}
|
|
|
|
install_requires = open('requirements.txt').read().strip().split('\n')
|
|
-subprocess.call(["git", "status"], stdout=sys.stdout, stderr=sys.stderr)
|
|
|
|
setup(
|
|
name='fastparquet',
|
|
@@ -57,8 +56,7 @@ setup(
|
|
'setuptools>18.0',
|
|
'setuptools-scm>1.5.4',
|
|
'Cython',
|
|
- 'pytest-runner',
|
|
- 'oldest-supported-numpy'
|
|
+ 'numpy'
|
|
],
|
|
description='Python support for Parquet file format',
|
|
author='Martin Durant',
|