freebsd-ports/databases/mysql57-client/files/patch-libmysql_CMakeLists.txt
Thomas Zander f83159f188 Update to 5.7.12, fixing 31 partially critical vulnerabilities
List of vulnerabilities is documented on:
http://vuxml.freebsd.org/freebsd/8c2b2f11-0ebe-11e6-b55e-b499baebfeaf.html
CVE IDs see below.

PR:		206998
Submitted by:	mokhi64@gmail.com (maintainer)
Reviewed by:	rootservice@gmail.com
Approved by:	mokhi64@gmail.com (maintainer)
MFH:		2016Q2
Security:	CVE-2016-0705
		CVE-2016-0639
		CVE-2015-3194
		CVE-2016-0640
		CVE-2016-0641
		CVE-2016-3461
		CVE-2016-2047
		CVE-2016-0642
		CVE-2016-0643
		CVE-2016-0644
		CVE-2016-0646
		CVE-2016-0647
		CVE-2016-0648
		CVE-2016-0649
		CVE-2016-0650
		CVE-2016-0652
		CVE-2016-0653
		CVE-2016-0654
		CVE-2016-0655
		CVE-2016-0656
		CVE-2016-0657
		CVE-2016-0658
		CVE-2016-0651
		CVE-2016-0659
		CVE-2016-0661
		CVE-2016-0662
		CVE-2016-0663
		CVE-2016-0665
		CVE-2016-0666
		CVE-2016-0667
		CVE-2016-0668
2016-05-06 14:39:59 +00:00

11 lines
428 B
Text

--- libmysql/CMakeLists.txt.orig 2016-03-28 18:06:12 UTC
+++ libmysql/CMakeLists.txt
@@ -260,7 +260,7 @@ IF(NOT DISABLE_SHARED)
COMPONENT SharedLibraries)
IF(UNIX)
# libtool compatability
- IF(CMAKE_SYSTEM_NAME MATCHES "FreeBSD" OR APPLE)
+ IF(CMAKE_SYSTEM_NAME MATCHES "FreeBSD|DragonFly" OR APPLE)
SET(OS_SHARED_LIB_VERSION "${SHARED_LIB_MAJOR_VERSION}")
ELSE()
SET(OS_SHARED_LIB_VERSION