e88031e534
Install the newly bundled tools: mailutil, dmail and tmail. Tidy. Add WITH_SSL_AND_PLAINTEXT knob, if you want to use plaintext passwords. Pointy hat to: dougb
69 lines
1.9 KiB
Text
69 lines
1.9 KiB
Text
--- src/imapd/Makefile.orig Mon Nov 18 17:48:25 2002
|
|
+++ src/imapd/Makefile Wed Nov 27 02:28:00 2002
|
|
@@ -18,10 +18,10 @@
|
|
# CPYRIGHT, included with this Distribution.
|
|
|
|
|
|
-ALERT=/etc/imapd.alert
|
|
+ALERT=$(PREFIX)/etc/imapd.alert
|
|
USERALERT=.imapalert
|
|
SHUTDOWN=/etc/nologin
|
|
-ANO=/etc/anonymous.newsgroups
|
|
+ANO=$(PREFIX)/etc/anonymous.newsgroups
|
|
SHELL= /bin/sh
|
|
|
|
|
|
@@ -29,7 +29,9 @@
|
|
# causes the "Manage Mail" menu item to open the given URL, e.g. to point to
|
|
# an alternative IMAP client (e.g. Pine) or perhaps to a homebrew mail
|
|
# account management page.
|
|
-#NSBD= -DNETSCAPE_BRAIN_DAMAGE=\"http://www.washington.edu/pine\"
|
|
+.if defined(WITH_NETSCAPE_BRAIN_DAMAGE)
|
|
+NSBD= -DNETSCAPE_BRAIN_DAMAGE=\"http://www.washington.edu/pine\"
|
|
+.endif
|
|
|
|
|
|
|
|
@@ -38,28 +40,29 @@
|
|
# broken program does a STATUS on the selected mailbox. This shouldn't be
|
|
# necessary, and it's been reported that Entourage works without having to
|
|
# un-comment this.
|
|
-#ENBD= -DENTOURAGE_BRAIN_DAMAGE
|
|
+.if defined(WITH_ENTOURAGE_BRAIN_DAMAGE)
|
|
+ENBD= -DENTOURAGE_BRAIN_DAMAGE
|
|
+.endif
|
|
|
|
|
|
# Get local definitions from c-client directory
|
|
|
|
C = ../c-client
|
|
-CCLIENTLIB = $C/c-client.a
|
|
-CC = `cat $C/CCTYPE`
|
|
-CFLAGS = -I$C `cat $C/CFLAGS` $(NSBD) $(ENBD) \
|
|
- -DANOFILE=\"$(ANO)\" -DALERTFILE=\"$(ALERT)\" \
|
|
- -DUSERALERTFILE=\"$(USERALERT)\" -DSHUTDOWNFILE=\"$(SHUTDOWN)\"
|
|
-LDFLAGS = $(CCLIENTLIB) `cat $C/LDFLAGS`
|
|
+#CCLIENTLIB = $C/c-client.a
|
|
+CFLAGS+= -DNFSKLUDGE -I$(LOCALBASE)/include/c-client -DANOFILE=\"$(ANO)\" \
|
|
+ -DALERTFILE=\"$(ALERT)\" -DUSERALERTFILE=\"$(USERALERT)\" \
|
|
+ -DSHUTDOWNFILE=\"$(SHUTDOWN)\"
|
|
+LDFLAGS+= $(EXTRALDFLAGS) -L$(LOCALBASE)/lib -lc-client4
|
|
+.if defined(WITH_DRAC)
|
|
+CFLAGS+= -DETC_DIR=\"$(PREFIX)/etc\" -DDRAC_AUTH
|
|
+LDFLAGS+= -ldrac
|
|
+.endif
|
|
+CFLAGS+= $(NSBD) $(ENBD)
|
|
|
|
all: imapd
|
|
|
|
-imapd: $(CCLIENTLIB) imapd.o
|
|
+imapd: imapd.o
|
|
$(CC) $(CFLAGS) -o imapd imapd.o $(LDFLAGS)
|
|
-
|
|
-imapd.o: $C/mail.h $C/misc.h $C/osdep.h
|
|
-
|
|
-$(CCLIENTLIB):
|
|
- cd $C;make
|
|
|
|
clean:
|
|
rm -f *.o imapd || true
|