freebsd-ports/lang/rexx-regutil/files/patch-regstem.c
Kurt Jaeger 8489b4ac92 lang/rexx-regutil: several patches
- additional MASTER_SITE (there was only one)
- tidied Makefile considerably
- fixed failure to build under different PREFIX
- added DOC option
- added EXAMPLES option, and now can have examples (there were none before)
- eliminated numerous compilation warnings
- REMOVED pkg-plist (only two files in it)
- REMOVED pkg-message (now redundant)
- ADDED new patches in files/

PR:		209379
Submitted by:	bob@eager.cx (maintainer)
2016-05-08 17:50:04 +00:00

11 lines
414 B
C

--- regstem.c.orig 2004-06-15 19:15:06 UTC
+++ regstem.c
@@ -53,7 +53,7 @@ static int rxstrcasecmp(const PRXSTRING
{
register int len = min(l->strlength, r->strlength),
d = l->strlength - r->strlength,
- c = casecmp(l->strptr, r->strptr, len);
+ c = casecmp((unsigned char *) l->strptr, (unsigned char *) r->strptr, len);
return (len && c) ? c : d;
}