freebsd-ports/security/nmap/files/patch-aa
Crist J. Clark 4f3bf60ae3 Do not try to install any parts of nmapfe from the nmap port. There is
a separate port for nmapfe. Even though the attempt in the nmap port
mostly fails since no nmapfe executable would have been built, files
not appearing in the pkg-plist were being added to the system.

PR:		ports/35207
Approved by:	obrien
2002-02-23 06:04:44 +00:00

25 lines
1.4 KiB
Text

--- Makefile.in.orig Fri Mar 9 22:25:19 2001
+++ Makefile.in Sun May 27 17:49:17 2001
@@ -16,5 +16,5 @@
CCOPT =
LIBPCAPDIR = @libpcapdir@
-INCLS = -I$(LIBPCAPDIR)
+#INCLS = -I$(LIBPCAPDIR)
DEFS = @DEFS@ -DNMAP_VERSION=\"$(NMAP_VERSION)\" -DNMAP_NAME=\"$(NMAP_NAME)\" -DNMAP_URL=\"$(NMAP_URL)\" -DNMAP_PLATFORM=\"$(NMAP_PLATFORM)\" -DNMAPDATADIR=\"$(nmapdatadir)\"
CFLAGS = -g @CFLAGS@ $(CCOPT) $(DEFS) $(INCLS)
@@ -171,9 +171,12 @@
$(MAKEDEPEND) $(INCLS) -s "# DO NOT DELETE" -- $(DEFS) -- $(SRCS)
-install: $(TARGET)
- $(SHTOOL) mkdir -f -p -m 755 $(bindir) $(mandir)/man1 $(nmapdatadir) $(deskdir)
- $(INSTALL) -c -m 755 nmap $(bindir)/nmap
+install-nmapfe:
@echo "If the next command fails -- you cannot use the X front end"
+ $(SHTOOL) mkdir -f -p -m 755 $(deskdir)
-test -f nmapfe/nmapfe && $(INSTALL) -c -m 755 nmapfe/nmapfe $(bindir)/nmapfe && $(SHTOOL) mkln -f -s $(bindir)/nmapfe $(bindir)/xnmap && $(INSTALL) -c -m 644 nmapfe.desktop $(deskdir)/nmapfe.desktop && $(INSTALL) -c -m 644 docs/nmapfe.1 $(mandir)/man1/nmapfe.1 && $(INSTALL) -c -m 644 docs/xnmap.1 $(mandir)/man1/xnmap.1
+
+install: $(TARGET)
+ $(SHTOOL) mkdir -f -p -m 755 $(bindir) $(mandir)/man1 $(nmapdatadir)
+ $(INSTALL) -c -m 755 nmap $(bindir)/nmap
$(INSTALL) -c -m 644 docs/$(TARGET).1 $(mandir)/man1/$(TARGET).1
$(INSTALL) -c -m 644 nmap-os-fingerprints $(nmapdatadir)/nmap-os-fingerprints