freebsd-ports/games/nethack34-qt/files/src-Makefile.diff
Andreas Klemm 724bd478c9 NetHack with Qt interface. Version 0.9 (for NetHack 3.2.2)
by Warwick Allison warwick@cs.uq.edu.au.

The Qt interface has these extra features:

    Tiles (graphics) in the inventory and other item-menu windows.
    The player cursor changes colour as your relative hit-points drop.
    The message window greys-out older message.
    The item menus allow a count (click to left of icon - hidden feature).
    Icons for the major attributes and player states.
    Menus (only needed by newbie dungeon fodder).
    Variable size fonts and tiles.
    More space for the map as messages and status are side-by-side.
    You rarely need to put the mouse in a pop-up to interact with it.
    Macros - hidden feature - F1=multi-rest F2=multi-search F3=try-it
    It is much easier to code, so new feature-requests are more easily done.
    Sound support

See: http://www.uq.edu.au/~cswallis/nhqt/
1997-04-06 02:45:30 +00:00

39 lines
1.3 KiB
Diff

--- src/Makefile.orig Sat Apr 5 19:43:25 1997
+++ src/Makefile Sat Apr 5 19:51:26 1997
@@ -124,11 +124,11 @@
# flags for debugging:
# CFLAGS = -g -I../include
-CFLAGS = -O2 -I../include
-LFLAGS = -L/usr/X11/lib -L$(QTDIR)/lib
+CFLAGS = -pipe -O -I../include
+LFLAGS = -L/usr/X11R6/lib -L$(QTDIR)/lib
# For USER_SOUNDS support, include -I/usr/X11/include
-CXXFLAGS = $(CFLAGS) -I. -I$(QTDIR)/include -I/usr/X11/include
+CXXFLAGS = $(CFLAGS) -I. -I/usr/X11R6/include -I/usr/X11R6/include/X11/qt
# Set the WINSRC, WINOBJ, and WINLIB lines to correspond to your desired
# combination of windowing systems. Also set windowing systems in config.h.
@@ -213,7 +213,7 @@
# IRIX 4.0.x needs -lsun if NIS (YP) is being used for passwd file lookup
# LIBS = -lsun
#
-LIBS =
+LIBS = -lgnuregex
# make NetHack
GAME = nethack
@@ -536,6 +536,12 @@
# DO NOT DELETE THIS LINE
+qaudio-p.moc: ../win/Qt/qaudio-p.h
+ moc ../win/Qt/qaudio-p.h > qaudio-p.moc
+qaudio-p.o: ../win/Qt/qaudio-p.cc qaudio-p.moc
+ $(CXX) $(CXXFLAGS) -c ../win/Qt/qaudio-p.cc
+qaudio.o: ../win/Qt/qaudio.cc
+ $(CXX) $(CXXFLAGS) -c ../win/Qt/qaudio.cc
qt_win.o: ../win/Qt/qt_win.cc ../include/hack.h ../include/qt_win.h ../include/cluster.h qt_win.moc
$(CXX) $(CXXFLAGS) -c ../win/Qt/qt_win.cc
qviewp.o: ../win/Qt/qviewp.cc ../include/qviewp.h qviewp.moc