903b45dfc5
merely pick up and help him. Thanks to many testers in both private and mailing list emails for report a few of build and dependencies problems. Also, thanks to marcus and Chess Griffin for test in their tinderboxes. x11/pixman: Update to 0.10.0 ------------------------------------------------------- Firefox 3 needs it. Orignal, the shared library was bumped and ahze has added a new feature in our USE_GNOME=ltverhack by can control the number of shared library. To control the number of shared library, add the ltverhack:N. Right now pixman has USE_GNOME=ltverhack:9 to make it stays same at libpixman-1.so.9. If anyone want to use ltverhack:N in one of your port, you need to make sure the ABI doesn't change to use it.. ------------------------------------------------------- graphics/cairo: Update to 1.6.4 ------------------------------------------------------- Firefox 3 needs it. We have updated most cairo binding ports too. ------------------------------------------------------- graphics/poppler: Update to 0.8.3 ------------------------------------------------------- The shared libraries version have been changed. All ports that depend on poppler have PORTREVISION bump. The graphics/py-poppler has been updated to 0.8.1 to work with newer poppler better. As for the poppler-qt, there is no shared library version change. ------------------------------------------------------- www/firefox3 and gecko ports related: Update to 3.0 final ------------------------------------------------------- The bsd.gecko.mk has been moved from www/mozilla/ to Mk/. You no longer need to include bsd.gecko.mk/Makefile.common by manual. We are keeping it in backward compatibility, so the rest ports won't be break. We haven't add some other ports to have Firefox 3 support yet, so feel free to send us patch or commit it by yourself (to committers). However, view in bsd.gecko.mk for document. ------------------------------------------------------- Approved by: portmgr (marcus)
20 lines
544 B
C
20 lines
544 B
C
--- content/xslt/public/txDouble.h.orig Fri Oct 13 00:00:29 2006
|
|
+++ content/xslt/public/txDouble.h Fri Oct 13 00:00:53 2006
|
|
@@ -41,7 +41,7 @@
|
|
#define __txdouble_h__
|
|
|
|
//A trick to handle IEEE floating point exceptions on FreeBSD - E.D.
|
|
-#ifdef __FreeBSD__
|
|
+/* #ifdef __FreeBSD__
|
|
#include <ieeefp.h>
|
|
#ifdef __alpha__
|
|
fp_except_t allmask = FP_X_INV|FP_X_OFL|FP_X_UFL|FP_X_DZ|FP_X_IMP;
|
|
@@ -50,7 +50,7 @@
|
|
#endif
|
|
fp_except_t oldmask = fpsetmask(~allmask);
|
|
#endif
|
|
-
|
|
+*/
|
|
/**
|
|
* Macros to workaround math-bugs bugs in various platforms
|
|
*/
|