903b45dfc5
merely pick up and help him. Thanks to many testers in both private and mailing list emails for report a few of build and dependencies problems. Also, thanks to marcus and Chess Griffin for test in their tinderboxes. x11/pixman: Update to 0.10.0 ------------------------------------------------------- Firefox 3 needs it. Orignal, the shared library was bumped and ahze has added a new feature in our USE_GNOME=ltverhack by can control the number of shared library. To control the number of shared library, add the ltverhack:N. Right now pixman has USE_GNOME=ltverhack:9 to make it stays same at libpixman-1.so.9. If anyone want to use ltverhack:N in one of your port, you need to make sure the ABI doesn't change to use it.. ------------------------------------------------------- graphics/cairo: Update to 1.6.4 ------------------------------------------------------- Firefox 3 needs it. We have updated most cairo binding ports too. ------------------------------------------------------- graphics/poppler: Update to 0.8.3 ------------------------------------------------------- The shared libraries version have been changed. All ports that depend on poppler have PORTREVISION bump. The graphics/py-poppler has been updated to 0.8.1 to work with newer poppler better. As for the poppler-qt, there is no shared library version change. ------------------------------------------------------- www/firefox3 and gecko ports related: Update to 3.0 final ------------------------------------------------------- The bsd.gecko.mk has been moved from www/mozilla/ to Mk/. You no longer need to include bsd.gecko.mk/Makefile.common by manual. We are keeping it in backward compatibility, so the rest ports won't be break. We haven't add some other ports to have Firefox 3 support yet, so feel free to send us patch or commit it by yourself (to committers). However, view in bsd.gecko.mk for document. ------------------------------------------------------- Approved by: portmgr (marcus)
28 lines
599 B
C
28 lines
599 B
C
--- js/src/jsnum.c.orig Sun Nov 5 18:37:07 2006
|
|
+++ js/src/jsnum.c Sun Nov 5 18:42:31 2006
|
|
@@ -45,6 +45,9 @@
|
|
#if defined(XP_WIN) || defined(XP_OS2)
|
|
#include <float.h>
|
|
#endif
|
|
+#if defined(__FreeBSD__)
|
|
+#include <sys/param.h>
|
|
+#endif
|
|
#include <locale.h>
|
|
#include <limits.h>
|
|
#include <math.h>
|
|
@@ -532,7 +535,15 @@ static jsdouble NaN;
|
|
|
|
#else
|
|
|
|
+#if defined(__FreeBSD__) && __FreeBSD_version >= 601000
|
|
+#include <fenv.h>
|
|
+#define FIX_FPU() (fedisableexcept(FE_ALL_EXCEPT))
|
|
+
|
|
+#else
|
|
+
|
|
#define FIX_FPU() ((void)0)
|
|
+
|
|
+#endif /* defined(__FreeBSD__) && __FreeBSD_version >= 503000 */
|
|
|
|
#endif
|
|
|