freebsd-ports/devel/ice/files/patch-php-lib-Makefile
Matthias Andree 35717bde57 Overhaul devel/ice, devel/py-ice and devel/php5-ice:
Changes from [*]:
- Update Ice to 3.5.1.
- Stageify all three ports.
- Convert py-ice and php5-ice to slave ports.
- Use ICONV_LIB, so it builds ok with native iconv [1].
- Workaround for FreeBSD 10's static destructor order disaster [2].
- Install man pages.
- Allow package build for non-root users.
[1] http://www.freebsd.org/doc/en_US.ISO8859-1/books/porters-handbook/using-iconv.html
[2] http://lists.freebsd.org/pipermail/freebsd-ports/2013-June/084580.html

Changes from [3]:
- Convert LIB_DEPENDS to new syntax.
- USE_GMAKE -> USES
- list Berkeley DB 6 invalid, requires upstream changes, but upstream is
  loathe to make those due to licensing change in BDB
- remove BDB 2 and 3 from invalid listing, we no longer have these ports

PR:		ports/184453 [*]
PR:		ports/185569 [3]
Submitted by:	Michael Gmelin (maintainer) [*]
Submitted by:	mandree [3]
Approved by:	Michael Gmelin (maintainer) [3]
2014-01-09 01:57:20 +00:00

12 lines
434 B
Text

--- php/lib/Makefile.orig 2013-06-02 12:11:06.451195440 +0000
+++ php/lib/Makefile 2013-06-02 12:16:29.249191742 +0000
@@ -167,7 +167,8 @@
@echo "Installing generated code"
@for i in $(MODULES) ; \
do \
- $(INSTALL_DATA) -r $$i $(DESTDIR)$(install_phpdir) ; \
+ mkdir -p $(DESTDIR)$(install_phpdir)/$$i ; \
+ $(INSTALL_DATA) $$i/*.php $(DESTDIR)$(install_phpdir)/$$i ; \
done
@for i in $(MODULE_SRCS) ; \
do \