83ab839c2b
-Update to 2.2.1, see the detail: http://www.abisource.com/release-notes/2.2.1.phtml
38 lines
1.4 KiB
Text
38 lines
1.4 KiB
Text
--- src/Makefile.orig Mon Dec 22 13:06:12 2003
|
|
+++ src/Makefile Sun Mar 28 15:29:40 2004
|
|
@@ -52,6 +52,7 @@
|
|
|
|
## Set the following to a list of pathnames to be copied to $(CANONDIR)
|
|
CANON_TOPLEVELFILES= $(ABI_ROOT)/COPYING $(ABI_ROOT)/user/wp/readme.txt
|
|
+CANON_TLF_NOTDIR= $(notdir $(CANON_TOPLEVELFILES))
|
|
|
|
## Set the following to a list of directories (probably a subset of DIRS)
|
|
## that have work to do.
|
|
@@ -62,6 +63,9 @@
|
|
@for k in $(CANON_TOPLEVELFILES); do \
|
|
$(ABICOPY) $$k $(CANONDIR); \
|
|
done
|
|
+ @for k in $(CANON_TLF_NOTDIR); do \
|
|
+ $(ABICHMOD) ugo=r $(CANONDIR)/$$k; \
|
|
+ done
|
|
@for k in $(CANON_SubDirs); do \
|
|
$(MAKE) ABI_ROOT=$(ABI_ROOT) -C $$k canonical; \
|
|
done
|
|
@@ -83,6 +87,7 @@
|
|
ifeq ($(ABI_OPT_PSPELL),1)
|
|
echo "Using Pspell build, not installing ispell hash files"
|
|
else
|
|
+ @(cd $(CANONDIR)/dictionary; $(ABICHMOD) ugo=r *)
|
|
# We currently only ship american.hash
|
|
@$(subst xxxx,$(CANONDIR)/dictionary,$(VERIFY_DIRECTORY))
|
|
@$(ABICOPY) $(ABI_ROOT)/../abidistfiles/dictionary/$(OS_ENDIAN).american.hash $(CANONDIR)/dictionary/american.hash
|
|
@@ -92,7 +97,8 @@
|
|
ifeq ($(ABI_NATIVE),unix)
|
|
# icons for X window manager use
|
|
@$(subst xxxx,$(CANONDIR)/icons,$(VERIFY_DIRECTORY))
|
|
- (cd $(ABI_ROOT)/../abidistfiles/icons; cp abi* $(CANONDIR)/icons)
|
|
+ (cd $(ABI_ROOT)/../abidistfiles/icons; $(ABICOPY) abi* $(CANONDIR)/icons)
|
|
+ @(cd $(CANONDIR)/icons; $(ABICHMOD) ugo=r abi*)
|
|
endif
|
|
|
|
@$(subst xxxx,$(CANONDIR)/clipart,$(VERIFY_DIRECTORY))
|